Skip to content

Commit

Permalink
dev-util/dialog: Bump to version 1.3.20160424
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Apr 25, 2016
1 parent f78b325 commit cc5e6ad
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/dialog/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dialog-1.2-20150920.tgz 498181 SHA256 c4e61ec5768701683dd4b5b2ebd8a31e6289fa6a1f5801e4b481085650698c05 SHA512 9cc0005ef6a0d7dc0b8263a433b0955fd8331fec9bceb0676dfb17da566d73216a089eab85b804918017623b98653bdb6b4e809a99ecf638f5a529dcf6314e48 WHIRLPOOL 7387fe72b56b20850826506b844e3d4378e7287aa67fc04b3f72d5684b34229fa14351ec2b8542c72b8a303c7c9819b8ead699575ad8eb90707d5e10de077e07
DIST dialog-1.3-20160209.tgz 499300 SHA256 0314f7f2195edc58e7567a024dc1d658c2f8ea732796d8fa4b4927df49803f87 SHA512 77ad7698c8acc9ec2c4a8e76d73972ed3ee8d323cdb8cb18fbe496ebe4a6c8be873e0e2ecf66bbeb7eb6c398d0ca125969cb068e89c33a17521e1e1b913b1e4a WHIRLPOOL 7faf2cb0c01bd314af61d1d180d78232ba57fbb5985f18365256888e29430d3bd8c65de38a5d51045e0fd05bd72d84cf7869ed86aa9bc37fb73ff64c2a795c30
DIST dialog-1.3-20160424.tgz 500829 SHA256 47f5870876e778aa2902f2e91b4070418d4651b647e1a67a94127cb8aab5b5eb SHA512 387cca610654c5fb3bc7ea0437787356bed14fbaff8c3440e5423f980b89f79e1d98903e3103065a54d0476986e32a6061ed2b05a2ab76ad918fd31861294df5 WHIRLPOOL b3348450315186111d7712ec253f970843052e9772955e987a935019167bf21a34c6b9639f3142a8dbfd48a13c67858fcf87318f86318d8d841533745d80a444
52 changes: 52 additions & 0 deletions dev-util/dialog/dialog-1.3.20160424.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils multilib versionator

MY_P="${PN}-$(replace_version_separator 2 '-')"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="tool to display dialog boxes from a shell"
HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
SRC_URI="ftp://invisible-island.net/${PN}/${MY_P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE="examples minimal nls static-libs unicode"

RDEPEND="
>=sys-libs/ncurses-5.2-r5:=[unicode?]
"
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
!minimal? ( sys-devel/libtool )
!<=sys-freebsd/freebsd-contrib-8.9999
"

src_prepare() {
default
sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
}

src_configure() {
econf \
--disable-rpath-hack \
$(use_enable nls) \
$(use_with !minimal libtool) \
--with-libtool-opts=$(usex static-libs '' '-shared') \
--with-ncurses$(usex unicode w '')
}

src_install() {
use minimal && default || emake DESTDIR="${D}" install-full

use examples && dodoc -r samples

dodoc CHANGES README

prune_libtool_files
}

0 comments on commit cc5e6ad

Please sign in to comment.