Skip to content

Commit

Permalink
dev-ruby/rinku: add 2.0.6
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
graaff committed Apr 23, 2019
1 parent 222244f commit ccaeb34
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rinku/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rinku-2.0.4.gem 21504 BLAKE2B cabb91710eca3f6d4985042045c1ebd37063abc466a2071c9a1c2f16f6efcdb80914eec855cc5c0795b428b285fcd6d760437ab2716cb3358e9a8e96b7916367 SHA512 fab4b47a22153d96f71e8b3c6e91595ba3ce97002233b035ab8ebcd6fb46a8e4ca2f82e49ed6d7a510338bd2ebec1b2e67d9146e589535fc8a072ae69e39d58f
DIST rinku-2.0.5.gem 22016 BLAKE2B 962b2e369ec91022f61d640ed604939e4a5db561cc594d54199ed83fd166302c2a0b5dba5976af4b7fb048ed6ab78e578a7ba33933005ecd19ac8be3269ed652 SHA512 7a0f3c906ddb190344033fbc19aeace137bc234a164fcbc4311ce31972f98398bc6fc10ad89926a212544a0c67369af333a9f7e1d865bfe1119447de44f6e588
DIST rinku-2.0.6.gem 22016 BLAKE2B 9ba678996110a219e4a5121879597f5024c5bfe475af187d9557092ac871f16528e473b41d20742847127b9c7ae665b91e5db7b9aab42dddd32e2a51f20815bb SHA512 5acb6de775e050a92c7b1040af52c5399b3fea654f7569d58aa1b5db10e4f17a2e1ae7ecc05f3753be4e18bbdf63ccd8e62d4060c0c6693981c8bab7115b2ff7
31 changes: 31 additions & 0 deletions dev-ruby/rinku/rinku-2.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby24 ruby25 ruby26"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.markdown"

inherit multilib ruby-fakegem

DESCRIPTION="A Ruby library that does autolinking"
HOMEPAGE="https://github.com/vmg/rinku"

LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}

each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/${PN}$(get_modname) lib/ || die
}

each_ruby_test() {
MT_NO_PLUGINS=true ${RUBY} -Ilib test/autolink_test.rb || die
}

0 comments on commit ccaeb34

Please sign in to comment.