Skip to content

Commit

Permalink
dev-lua/busted: version bump to 2.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Victor Payno <[email protected]>
Closes: gentoo#14478
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
vpayno authored and gyakovlev committed Mar 16, 2020
1 parent b6f2224 commit cd013a2
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/busted/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST busted-2.0.0.tar.gz 55002 BLAKE2B 39a3b7bf156911e25f94020f9e56b3f43b9f02b910a9d1c1f288dbdb83e5d53253d5b40d73df655844ed683cff7959d42c330c0d061db918385df07870e16da3 SHA512 3151694b1fba1acc52e3bcfee0231008b14934e89da5885d7e063c6f023479c42040c42a8c0aa6ff1f8303ad6b2a70f0687c8a218830de7231007ef8748457bf
DIST busted-2.0_rc11_p0.tar.gz 48368 BLAKE2B 3e4534795a4d6bd816b9879d447b82e144f738f3601856e5c9fc5419a6b8f3cb57a78a9ce6ad90990c1abe9fe0974b809d10a942b5f4930b4120f98d34de0dbe SHA512 f09cd5ad2be05b37254e9d602433639340b020e0670e8a435f1ee1d312eced37e284c2f5a398d7a0403fac0023851b74dbe659373e495c5354f48baed814c4b8
DIST busted-2.0_rc12_p1.tar.gz 52404 BLAKE2B 51f12aea26d6b0909fdbf8953b316814ff8cd76d39358a26eb785ac7541acddbfde1b19d2e41c9e966a604f8f00b9517181f87264a76a4ac7f9f8d6008c87692 SHA512 0cb1f6a66110514dc3675b2e667cca676e6672e895b57ffba438e89a1e0a7f4f8f941cab54ead905758987be15e9885e1eeb82baabc9d18bf29ea56b832b89b1
48 changes: 48 additions & 0 deletions dev-lua/busted/busted-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="Elegant Lua unit testing"
HOMEPAGE="http://olivinelabs.com/busted/"
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-lang/lua-5.1:=
>=dev-lua/lua_cliargs-3.0
>=dev-lua/luafilesystem-1.5.0
>=dev-lua/luasystem-0.2.0
>=dev-lua/dkjson-2.1.0
>=dev-lua/say-1.3
>=dev-lua/luassert-1.7.8
>=dev-lua/lua-term-0.1_p1
>=dev-lua/penlight-1.3.2
>=dev-lua/mediator_lua-1.1.1_p0
"
BDEPEND="
virtual/pkgconfig
test? (
${RDEPEND}
>=dev-lua/busted-2.0.0
)
"
DEPEND="${RDEPEND}"

src_test() {
busted ./spec || die
}

src_install() {
dobin bin/busted
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
doins -r busted/*
dodoc *.md
}

0 comments on commit cd013a2

Please sign in to comment.