Skip to content

Commit

Permalink
net-misc/htun: Fix multiple symbol definitions
Browse files Browse the repository at this point in the history
Gentoo-bug: 571458
* EAPI=6
* Made PATCHES -p1 compliant
* Respect CFLAGS

Package-Manager: portage-2.3.3
  • Loading branch information
SoapGentoo committed Dec 11, 2016
1 parent dc4c700 commit cddcbd4
Show file tree
Hide file tree
Showing 3 changed files with 32 additions and 13 deletions.
4 changes: 2 additions & 2 deletions net-misc/htun/files/htun-0.9.6-glibc.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@ get things building with glibc-2.8

http://bugs.gentoo.org/248100

--- include/common.h
+++ include/common.h
--- a/include/common.h
+++ b/include/common.h
@@ -23,6 +23,7 @@
#ifndef __COMMON_H
#define __COMMON_H
Expand Down
18 changes: 15 additions & 3 deletions net-misc/htun/files/htun-0.9.6-makefile.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,11 @@
--- src/Makefile 2005-10-27 12:58:53.000000000 +0200
+++ src/Makefile 2013-03-08 22:20:52.360922189 +0100
* Fix build system to not hardcode CC
* Fix build system to respect user flags

--- a/src/Makefile
+++ b/src/Makefile
@@ -20,16 +20,14 @@

# $Id$
# $Id: Makefile,v 2.16 2002/08/11 15:57:07 jehsom Exp $

-
-CFLAGS = -I../include -I. -O -W -Wall -g -D_REENTRANT #-pg -a
Expand All @@ -20,3 +23,12 @@
LEX = flex
YACC = yacc
INCLUDE := $(wildcard ../include/*.h)
@@ -52,7 +50,7 @@
$(OBJS): $(INCLUDE)

$(CONFOBS): $(CONFSRC)
- $(CC) $(LEX_CFLAGS) -c $(@:.o=.c)
+ $(CC) $(CFLAGS) $(LEX_CFLAGS) -c $(@:.o=.c)

lex.yy.c: parse.l
$(LEX) $^
23 changes: 15 additions & 8 deletions net-misc/htun/htun-0.9.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
EAPI=6

inherit eutils readme.gentoo
inherit flag-o-matic readme.gentoo-r1 toolchain-funcs

DESCRIPTION="Project to tunnel IP traffic over HTTP"
HOMEPAGE="http://linux.softpedia.com/get/System/Networking/HTun-14751.shtml"
Expand All @@ -19,11 +19,15 @@ KEYWORDS="~amd64 ~x86"
DEPEND="dev-util/yacc"
RDEPEND=""

src_prepare() {
epatch "${FILESDIR}"/${P}-glibc.patch #248100
epatch "${FILESDIR}"/${P}-makefile.patch
PATCHES=(
"${FILESDIR}"/${P}-glibc.patch #248100
"${FILESDIR}"/${P}-makefile.patch
)

epatch_user
src_configure() {
# Fix multiple symbol definitions due to
# C99/C11 inline semantics, bug 571458
append-cflags -std=gnu89
}

src_compile() {
Expand All @@ -32,8 +36,11 @@ src_compile() {

src_install() {
dosbin src/htund

insinto /etc
doins doc/htund.conf
dodoc doc/* README

local DOCS=( doc/. README )
einstalldocs
readme.gentoo_create_doc
}

0 comments on commit cddcbd4

Please sign in to comment.