Skip to content

Commit

Permalink
dev-python/oslo-messaging: 5.35.0 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
prometheanfire committed Feb 17, 2018
1 parent 8e2de9f commit ce3be45
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-messaging/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST oslo.messaging-5.30.2.tar.gz 317883 BLAKE2B 4003de476db2636eae2462cd3aef7bacb911e321c2cb228263482eda7a82361ec4c731872dbaa8394cfdb42759a8c5e200a03b919c0941f74da32498831394b2 SHA512 b4715c73c158414d1b65fd56c6697ff67ce24499e96ca076f8c3d5d93d0b06ca1f9f80fa0de43c5ee0d5e8de221f20b95e077738b026bac6671d1a2ec6128b08
DIST oslo.messaging-5.35.0.tar.gz 325918 BLAKE2B d219a630b0958930bdd84693f43030c34c7beddce42f017f7f5ffddf5a6530c59b3eb29c5110a468a4606715f766a62abe3bd2d77c79ce025beafee6f322321e SHA512 30989d9418d30570ce212110b263ac7227acc3d6cd05305f7df23844253a81265c76e3fd93228e13a25399f5188431fa2f959a2c15639162abb5297a6fb7d4a1
54 changes: 54 additions & 0 deletions dev-python/oslo-messaging/oslo-messaging-5.35.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
HOMEPAGE="https://pypi.python.org/pypi/oslo.messaging"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.messaging/oslo.messaging-${PV}.tar.gz"
S="${WORKDIR}/oslo.messaging-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/futurist-1.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
!~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
>=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
!~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
>=dev-python/py-amqp-2.1.1[${PYTHON_USEDEP}]
!~dev-python/py-amqp-2.1.4[${PYTHON_USEDEP}]
>=dev-python/kombu-4.0.0[${PYTHON_USEDEP}]
!~dev-python/kombu-4.0.2[${PYTHON_USEDEP}]
>=dev-python/pika-0.10.0[${PYTHON_USEDEP}]
>=dev-python/pika-pool-0.1.3[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
>=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

0 comments on commit ce3be45

Please sign in to comment.