Skip to content

Commit

Permalink
app-arch/wimlib: EAPI 7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 19, 2021
1 parent d079d04 commit ce709e1
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 31 deletions.
33 changes: 18 additions & 15 deletions app-arch/wimlib/wimlib-1.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,17 +1,17 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit autotools pax-utils

if [[ -z ${PV%%*9999} ]]; then
inherit git-r3
EGIT_REPO_URI="git://wimlib.net/${PN}"
else
inherit vcs-snapshot
MY_PV="${PV/_/-}"
MY_PV="${MY_PV^^}"
SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

Expand All @@ -20,28 +20,31 @@ HOMEPAGE="https://wimlib.net/"

LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
SLOT="0"
IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl threads yasm"
IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl test threads yasm"
REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"

PATCHES=( "${FILESDIR}/syslinux-path.patch" )
RESTRICT="!test? ( test )"

BDEPEND="
virtual/pkgconfig
cpu_flags_x86_ssse3? (
yasm? ( dev-lang/yasm )
!yasm? ( dev-lang/nasm )
)
"
RDEPEND="
dev-libs/libxml2:2
ntfs? ( sys-fs/ntfs3g )
fuse? ( sys-fs/fuse:0 )
openssl? ( dev-libs/openssl:0 )
openssl? ( dev-libs/openssl:0= )
iso? (
app-arch/cabextract
app-cdr/cdrtools
)
"
DEPEND="
${RDEPEND}
cpu_flags_x86_ssse3? (
yasm? ( dev-lang/yasm )
!yasm? ( dev-lang/nasm )
)
"
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}/syslinux-path.patch" )

src_prepare() {
default
Expand All @@ -55,9 +58,9 @@ src_configure() {
$(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
$(use_with openssl libcrypto)
$(use_enable threads multithreaded-compression)
$(use_enable test enable-test-support)
--disable-static
)
has test ${FEATURES} && myeconfargs+=( --enable-test-support )
ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
econf "${myeconfargs[@]}"
}
Expand Down
34 changes: 18 additions & 16 deletions app-arch/wimlib/wimlib-1.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,17 +1,16 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit autotools pax-utils
if [[ -z ${PV%%*9999} ]]; then
inherit git-r3
EGIT_REPO_URI="git://wimlib.net/${PN}"
else
inherit vcs-snapshot
MY_PV="${PV/_/-}"
MY_PV="${MY_PV^^}"
SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

Expand All @@ -20,28 +19,31 @@ HOMEPAGE="https://wimlib.net/"

LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
SLOT="0"
IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl threads yasm"
IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl test threads yasm"
REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"

PATCHES=( "${FILESDIR}/syslinux-path.patch" )
RESTRICT="!test? ( test )"

BDEPEND="
virtual/pkgconfig
cpu_flags_x86_ssse3? (
yasm? ( dev-lang/yasm )
!yasm? ( dev-lang/nasm )
)
"
RDEPEND="
dev-libs/libxml2:2
ntfs? ( sys-fs/ntfs3g )
fuse? ( sys-fs/fuse:0 )
openssl? ( dev-libs/openssl:0 )
openssl? ( dev-libs/openssl:0= )
iso? (
app-arch/cabextract
app-cdr/cdrtools
)
"
DEPEND="
${RDEPEND}
cpu_flags_x86_ssse3? (
yasm? ( dev-lang/yasm )
!yasm? ( dev-lang/nasm )
)
"
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}/syslinux-path.patch" )

src_prepare() {
default
Expand All @@ -55,15 +57,15 @@ src_configure() {
$(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
$(use_with openssl libcrypto)
$(use_enable threads multithreaded-compression)
$(use_enable test test-support)
--disable-static
)
has test ${FEATURES} && myeconfargs+=( --enable-test-support )
ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
econf "${myeconfargs[@]}"
}

src_compile() {
emake
default
pax-mark m "${S}"/.libs/wimlib-imagex
}

Expand Down

0 comments on commit ce709e1

Please sign in to comment.