Skip to content

Commit

Permalink
sci-mathematics/glpk: Upstream bump
Browse files Browse the repository at this point in the history
Closes: gentoo#18685
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: François René Pierre Bissey <[email protected]>
Signed-off-by: Michael Orlitzky <[email protected]>
  • Loading branch information
kiwifb authored and orlitzky committed Dec 17, 2020
1 parent 367482d commit ce8bb0f
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-mathematics/glpk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST glpk-4.65.tar.gz 4167110 BLAKE2B 4ccb5cd8301bdca2ccdecfc1648642afe26ff0a1ee9a75cb5a3906838086e5c41edfb16e7c55f4ad677d192f6a66b866f2d917c5be7103da7141bfb1f74e636b SHA512 997e8e599ff1718a08c66b86eadd0e01f4644899f1e95920f8ae91d66b4d8361021766b346845f4dcbcfe667b41ab72ea3d377017a0ebf85d7ece091cfd81375
DIST glpk-5.0.tar.gz 4132649 BLAKE2B f8204f66a97af950c13ee72ee9541f305745741d1231325670ede14663cb6c28ec6fbc44b3625973f1924ca078183d1d43f494ad43a7b48b45be131882b00001 SHA512 4e92195fa058c707146f2690f3a38b46c33add948c852f67659ca005a6aa980bbf97be96528b0f8391690facb880ac2126cd60198c6c175e7f3f06cca7e29f9d
76 changes: 76 additions & 0 deletions sci-mathematics/glpk/glpk-5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic toolchain-funcs

DESCRIPTION="GNU Linear Programming Kit"
HOMEPAGE="https://www.gnu.org/software/glpk/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0/40"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="doc examples gmp odbc mysql"

BDEPEND="virtual/pkgconfig"
DEPEND="
sci-libs/amd:0=
sci-libs/colamd:=
sys-libs/zlib:0=
gmp? ( dev-libs/gmp:0= )
mysql? ( dev-db/mysql-connector-c )
odbc? (
|| (
dev-db/libiodbc:0
dev-db/unixODBC:0
)
)"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-4.65-fix-mysql-include-prefix.patch
"${FILESDIR}"/${PN}-4.65-debundle-system-libs.patch
)

src_prepare() {
# TODO: the ODBC library is dlopen()ed, so we only want to append
# -I<foo> to the preprocessor flags, and not all of the CFLAGS that
# were used to build libiodbc. That fix and the pkg-config fallback
# should be sent upstream, and placed into CPPFLAGS rather than
# CFLAGS (as configure.ac does now).
use odbc && [[ -z $(type -P odbc_config) ]] && \
append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)

default
eautoreconf
}

src_configure() {
local myconf
if use mysql || use odbc; then
myconf="--enable-dl"
else
myconf="--disable-dl"
fi

econf ${myconf} \
--disable-static \
$(use_enable mysql) \
$(use_enable odbc) \
$(use_with gmp)
}

src_install() {
default
if use examples; then
insinto "/usr/share/doc/${PF}"
doins -r examples
docompress -x "/usr/share/doc/${PF}/examples"
fi
use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt

# no static archives
find "${D}" -name '*.la' -delete || die
}

0 comments on commit ce8bb0f

Please sign in to comment.