Skip to content

Commit

Permalink
dev-qt/qtwayland: Drop USE libinput
Browse files Browse the repository at this point in the history
USE -libinput is broken with dev-qt/qtgui[-libinput,X], would also need -X.

Closes: https://bugs.gentoo.org/711476
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 18, 2020
1 parent 914d231 commit cea8b36
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-qt/qtwayland/qtwayland-5.14.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit qt5-build

DESCRIPTION="Wayland platform plugin for Qt"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi

IUSE="vulkan X"

DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
vulkan? ( dev-util/vulkan-headers )
X? (
x11-libs/libX11
x11-libs/libXcomposite
)
"
RDEPEND="${DEPEND}"

src_prepare() {
use X || rm -r config.tests/xcomposite || die

qt5-build_src_prepare
}

src_configure() {
local myqmakeargs=(
--
$(qt_use vulkan feature-wayland-vulkan-server-buffer)
$(qt_use X feature-xcomposite-egl)
$(qt_use X feature-xcomposite-glx)
)
qt5-build_src_configure
}

0 comments on commit cea8b36

Please sign in to comment.