Skip to content

Commit

Permalink
games-rpg/daimonin-client: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Oct 14, 2016
1 parent f96f122 commit cef11d7
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 4 deletions.
71 changes: 71 additions & 0 deletions games-rpg/daimonin-client/daimonin-client-0.10.5-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils autotools

MY_P=${PN}-${PV}
DESCRIPTION="a graphical 2D tile-based MMORPG"
HOMEPAGE="http://daimonin.sourceforge.net/"
SRC_URI="http://daimonin.svn.sourceforge.net/viewvc/daimonin/main/client/?view=tar&pathrev=6021
-> daimonin-client-0.10.5.tar.gz
music? ( mirror://sourceforge/daimonin/Addon%20packs/Music/AllMusic.zip
-> daimonin-client-AllMusic-20100827.zip )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug music"

RDEPEND="
dev-games/physfs
media-libs/libsdl[sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
net-misc/curl"
DEPEND="${RDEPEND}
music? ( app-arch/unzip )"

S=${WORKDIR}/client/make/linux

PATCHES=(
"${FILESDIR}"/${P}-nozlib.patch
)

src_unpack() {
unpack ${MY_P}.tar.gz
if use music ; then
cd client/media || die
rm -f * || die
unpack ${PN}-AllMusic-20100827.zip
fi
}

src_prepare() {
default
rm ../../src/include/z{lib,conf}.h || die
sed -i \
-e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
-e '/PROGRAMS/s:daimonin-updater::' \
Makefile.am \
|| die "sed failed"
eautoreconf
cd ../../src || die
# Not relative to $S, so can't be applied via $PATCHES[@]
eapply "${FILESDIR}"/${P}-datadir.patch
}

src_configure() {
econf \
--disable-simplelayout \
$(use_enable debug)
}

src_install() {
default
cd ../.. || die
dodoc README*
newicon bitmaps/pentagram.png ${PN}.png
make_desktop_entry daimonin Daimonin
}
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- main.c.old 2010-08-24 19:32:55.000000000 +0200
+++ main.c 2010-09-19 18:49:54.000000000 +0200
--- a/main.c 2010-08-24 19:32:55.000000000 +0200
+++ b/main.c 2010-09-19 18:49:54.000000000 +0200
@@ -2386,7 +2386,7 @@

/* Add the base dir to the search path. The base dir is where all the
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.am.old 2010-12-01 14:39:11.605648458 -0500
+++ Makefile.am 2010-12-01 14:41:59.875915880 -0500
--- a/Makefile.am 2010-12-01 14:39:11.605648458 -0500
+++ b/Makefile.am 2010-12-01 14:41:59.875915880 -0500
@@ -2,23 +2,18 @@
daimonin_PROGRAMS = daimonin daimonin-updater

Expand Down

0 comments on commit cef11d7

Please sign in to comment.