Skip to content

Commit

Permalink
dev-vcs/fossil: version bump (bug #707902)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Rafael Martins <[email protected]>
  • Loading branch information
Rafael Martins committed Feb 2, 2020
1 parent bbe6daa commit cf6bf20
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-vcs/fossil/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST fossil-src-2.10.tar.gz 5634327 BLAKE2B 1a02ef0d32b06dd09760d6a62450ad7bc15de97b5263d50ec776dbf0e2fff6b6fba4ec944eecffdaf31737f4a45e30aa898a728590a0c6e2ae171937a349e92b SHA512 aad54e3eaa2d647257c5c723fca4e55981aac0432d3d0b4deaa9651c7db7d27cb9f26f7ff40c31c452cb8dd54b0f0663c632183dc11982bc9cc24adf78b952e5
DIST fossil-src-2.8.tar.gz 5359975 BLAKE2B 6b63eadc8cd563d646698edc9972a52ec1feb868cb362449c232c99dcb81fea2fa227d631ebf8b695417c571933784dfffd5ecbec2a5027ac9901578a054c559 SHA512 5c6a8dc1545c43b3c95fbbec343db023e27a9db58f282a881bb7e488e3e26a0f7913a41f505dedf618b884507e48956780bd0e12482e184345d68edd1e79ff8e
DIST fossil-src-2.9.tar.gz 5440118 BLAKE2B 2817e3c88073a26ef384d45271511eaacf5394a67ba6041ba0b37f321303abcba28655daf7963b8e51a8bc9bfeee681cea1f318f5ba66e93a5317b98771ad059 SHA512 c3786d4ae5517c88917819448863e9e1e37704a7073a1c87c042660313b77ce3a63f32e35e6a56af1c681e7b8a5acc652b4447d0387b8a8a5b3b5aa04dd9a9b5
57 changes: 57 additions & 0 deletions dev-vcs/fossil/fossil-2.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Simple, high-reliability, source control management, and more"
HOMEPAGE="http://www.fossil-scm.org/"
SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"

REQUIRED_USE="ssl? ( !miniz )"

DEPEND="
sys-libs/zlib
|| ( sys-libs/readline:0 dev-libs/libedit )
system-sqlite? ( >=dev-db/sqlite-3.28.0:3 )
ssl? ( dev-libs/openssl:0 )
tcl? ( dev-lang/tcl:0= )
"
RDEPEND="${DEPEND}"

# Tests can't be run from the build directory
RESTRICT="test"

src_configure() {
# this is not an autotools situation so don't make it seem like one
# --with-tcl: works
# --without-tcl: dies
local myconf="--with-openssl=$(usex ssl auto none)"
use debug && myconf+=' --fossil-debug'
use json && myconf+=' --json'
use system-sqlite && myconf+=' --disable-internal-sqlite'
use static && myconf+=' --static'
use tcl && myconf+=' --with-tcl=1'
use fusefs || myconf+=' --disable-fusefs'

local u useflags
useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
th1-docs th1-hooks )
for u in ${useflags[@]} ; do
use ${u} && myconf+=" --with-${u}"
done

tc-export CC
./configure ${myconf} || die
}

src_install() {
dobin fossil
}

0 comments on commit cf6bf20

Please sign in to comment.