Skip to content

Commit

Permalink
games-arcade/crack-attack: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 15, 2018
1 parent 8ec5088 commit cfa7edd
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 4 deletions.
47 changes: 47 additions & 0 deletions games-arcade/crack-attack/crack-attack-1.1.14-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop

DESCRIPTION="Addictive OpenGL-based block game"
HOMEPAGE="http://www.nongnu.org/crack-attack/"
SRC_URI="https://savannah.nongnu.org/download/crack-attack/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~x86"
IUSE="gtk sdl"

RDEPEND="
media-libs/freeglut
sdl? ( media-libs/libsdl
media-libs/sdl-mixer )
gtk? ( >=x11-libs/gtk+-2.6:2 )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"

src_prepare() {
default
eapply \
"${FILESDIR}"/${P}-glut.patch \
"${FILESDIR}"/${P}-gcc43.patch
sed -i 's/-lXmu//' src/gtk-gui/Makefile.in src/Makefile.in || die
touch -r . * */*
}

src_configure() {
econf \
--disable-binreloc \
$(use_enable sdl sound) \
$(use_enable gtk)
}

src_install() {
HTML_DOCS="doc/*"
default
doicon data/crack-attack.xpm
make_desktop_entry crack-attack Crack-attack
}
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Game.h
+++ src/Game.h
--- a/src/Game.h
+++ b/src/Game.h
@@ -34,6 +34,7 @@
#include <climits>
#include <cstdlib>
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@ Fix from upstream to work with newer freegluts.

http://bugs.gentoo.org/97954

--- src/Attack.cxx
+++ src/Attack.cxx
--- a/src/Attack.cxx
+++ b/src/Attack.cxx
@@ -83,6 +83,7 @@
int height = -1, width = -1;

Expand Down

0 comments on commit cfa7edd

Please sign in to comment.