Skip to content

Commit

Permalink
games-simulation/openrct2: update nightly
Browse files Browse the repository at this point in the history
currently some tests fail due to data not beeing found

Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
hvraven authored and mgorny committed May 9, 2018
1 parent e96a192 commit d0cfe5a
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 18 deletions.
2 changes: 1 addition & 1 deletion games-simulation/openrct2/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
DIST openrct2-0.1.2.tar.gz 6769785 BLAKE2B 0cc6ef6c68c1db6c822dd6038bc2d115f487a52b5891316273ee36db1713913baa2f119dabace88a37c16f87c90b14cf84df75a24b26b22571e98966afd2adbc SHA512 489dac96e1eda1449680f98a4b500eeb7b3f1ffbdaa5a5c701300071eb3a7862c65fa5a81e769083927b95a14914db54307724756a9841cff0c769c9e5471adc
DIST openrct2-title-sequence-v0.1.0.zip 1766393 BLAKE2B 19612ba78572c4f271349387a24fc9caf389552ad78841ed86ff069c20686da339c83cabe041a1ae240055721984372f1ef20bd009f1ac8b38bf3ff82297b29a SHA512 0d1b47c5fc5d1d9e5580b30d0f43d5532b388f1a5685060ca9313ec2f76c61a5fc96b8aa37689072b71edd9fb1aedddd46fa38c237ccb7198841d7bc33bf2a2b
DIST openrct2-objects-v1.0.zip 2050225 BLAKE2B 52ae6f5ab4de5d4b121cea6a3d6711b04f1c4857795c995f7568e3be2862409104be55e233781ff6708c7e821f49af8e91f9f4c87c037b6a8a77698534747925 SHA512 a125fee04c12c49ffd16880eb5b8722e25c5fb82adae305d9904c3a6251c83e73e4a29c7e3694acee3abf336894759cfbff94018c6b210df4d794ca3ec34dc84
DIST openrct2-title-sequence-v0.1.2.zip 4073116 BLAKE2B a36fb07e8da62afce129f2224f4cf5cc226922094132a3dc515fda1f02e0f8bbe07c973363f824ae58a54a26f252ad96f3f673bf5f142be5c964f45b6f712ed6 SHA512 7592c5397ceb27347c127ae5c4f8e11d7ef2ff23c97f627b354f941894420f546ffdcff88e2348e42c82d182ccf620e739c745d894a9b5650a0d7d028b68a106
50 changes: 33 additions & 17 deletions games-simulation/openrct2/openrct2-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=6

inherit cmake-utils gnome2-utils
inherit cmake-utils gnome2-utils xdg-utils

DESCRIPTION="An open source re-implementation of RollerCoaster Tycoon 2"
HOMEPAGE="https://openrct2.website/"
Expand All @@ -18,16 +18,16 @@ else
S="${WORKDIR}/OpenRCT2-${PV}"
fi

TSV="0.1.0"
TSV="0.1.2"
SRC_URI+=" https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip -> ${PN}-title-sequence-v${TSV}.zip "

OBJV="1.0"
SRC_URI+=" https://github.com/OpenRCT2/objects/releases/download/v${OBJV}/objects.zip -> ${PN}-objects-v${OBJV}.zip"

LICENSE="GPL-3"
SLOT="0"
IUSE="libressl +multiplayer opengl test truetype +twitch"

# This is needed because of this bug: https://github.com/OpenRCT2/OpenRCT2/issues/5469
REQUIRED_USE="multiplayer? ( twitch )"

RDEPEND="
>=dev-libs/jansson-2.5
>=dev-libs/libzip-1.0
Expand All @@ -47,15 +47,33 @@ RDEPEND="
twitch? ( net-misc/curl[ssl] )
"
DEPEND="${RDEPEND}
app-arch/unzip
test? ( dev-cpp/gtest )
"

if [[ ${PV} == 9999 ]]; then
src_unpack() {
default
git-r3_src_unpack
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
else
unpack ${P}.tar.gz
fi

mkdir -p "${S}/data/title" || die
pushd "${S}/data/title" || die
unpack ${PN}-title-sequence-v${TSV}.zip
popd || die

mkdir -p "${S}/data/object" || die
pushd "${S}/data/object" || die
unpack ${PN}-objects-v${OBJV}.zip
popd || die
}

src_prepare() {
sed -i CMakeLists.txt -e 's/-Werror//' || die

cmake-utils_src_prepare
}
fi

src_configure() {
local mycmakeargs=(
Expand All @@ -65,20 +83,14 @@ src_configure() {
-DDISABLE_TTF="$(usex !truetype)"
-DWITH_TESTS="$(usex test)"
-DDOWNLOAD_TITLE_SEQUENCES=OFF
-DDISABLE_RCT2_TESTS=ON
-DDOWNLOAD_OBJECTS=OFF
-DSYSTEM_GTEST=ON
-DBUILD_SHARED_LIBS=ON
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install

insinto /usr/share/openrct2/title
doins "${WORKDIR}"/*.parkseq
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
ewarn ""
Expand All @@ -87,8 +99,12 @@ pkg_postinst() {
ewarn ""
fi
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit d0cfe5a

Please sign in to comment.