Skip to content

Commit

Permalink
games-simulation/simutrans: fix missing text files
Browse files Browse the repository at this point in the history
Also remove deprecated games eclass

Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/580948
Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Sep 15, 2016
1 parent 9a223f2 commit d184c16
Show file tree
Hide file tree
Showing 3 changed files with 72 additions and 2 deletions.
1 change: 1 addition & 0 deletions games-simulation/simutrans/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST language_pack-Base+texts.zip 1097263 SHA256 3d2e637eb6018ccb5da99614dae7fc6ae1bdb0d8db4b2beea85d7e36ea5edf7c SHA512 015caafaeace03bd5475e66c93bb433d9b07b600c3fcf125a4bda9b2856ba41dc43b923e032920df4a060087ead7180df59092f23ab6dcf12579b580827b1248 WHIRLPOOL 679efda1f4bfa0bf71b2f4aa955cee287ee6e9c10d6b3f9070cb799eae5c7acd3651e59f3d8d46688f56ee9781e102e485ab59b6a16a4ee556b18c95b2c35fb3
DIST simupak64-120-0-1.zip 4051769 SHA256 02a709dfa4b0c22e0b463ebcbd9684548356de1c61566cff9c127a79990dbb78 SHA512 21badd251b9018bef55531923e23cb1935c3831784fab028febd3879384330e843329499ab08a08e71238fb92bf7db36e18ecbbc4e719a942e427f58fc634afc WHIRLPOOL 5ae84653b5a138b5a987b7ca6512994f3ba8dff48fffbb94f6fe0bf4845d5537e93734f73174eb328f20b6c9986235ae6c461c55b5efde53a4b81620a3b1da83
DIST simupak64-120-1-2.zip 4308534 SHA256 125fa5c13a51bb0630ca651fddb8af06a823e8c4d4638bfa1bb2d89e92cc1d54 SHA512 ddc75ad1cafa23d9a7387dc38b14de7414ea7c8bb7caa2afde6d8cdf9c3f5251719966b2274c5bc4ecc9915ec764d517e24b79d5ef199904e3d9185214cba129 WHIRLPOOL 4f91de57be620849f2a278df5510ea390d737a4f063dc659ed2d5f488ce0e631b1c15d6282554574b89316b3b968e4b850db8764b24b714df1a3c5e642e34907
DIST simutrans-src-120-0-1.zip 3909005 SHA256 010a6e3765891e1821364e54f6bcdfb2911b627ffca3acae8350e06e53113683 SHA512 6f32b6f1c12f45125de8a12c4a034387a784e21fd8cdedcf7b1daefd9174d9a94825e8f68effa2ff1436cce2e2bc8cb5707161f3fa004185ae158400840dc450 WHIRLPOOL 36155184f5806a9cfab742f26e3fc78d5d7d928f99cddabbaf36c7c90d065dab02bb174c07d9633958f8b891b0db8cc5c94e45fd4f22d917b9a037c51a99b69a
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.orig
+++ Makefile
--- a/Makefile
+++ b/Makefile
@@ -81,8 +81,6 @@
ifeq ($(findstring $(OSTYPE), amiga haiku mac),)
CFLAGS += -minline-all-stringops
Expand Down
69 changes: 69 additions & 0 deletions games-simulation/simutrans/simutrans-0.120.1.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit flag-o-matic eutils

MY_PV=${PV/0./}
MY_PV=${MY_PV//./-}
DESCRIPTION="A free Transport Tycoon clone"
HOMEPAGE="http://www.simutrans.com/"
SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
http://simutrans-germany.com/translator/data/tab/language_pack-Base+texts.zip
mirror://sourceforge/simutrans/simupak64-${MY_PV/3/2}.zip" #FIXME: rev bump when .3 is released

LICENSE="Artistic"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""

RDEPEND="
app-arch/bzip2
media-libs/libpng:0
media-libs/libsdl[sound,video]
media-libs/sdl-mixer
sys-libs/zlib"
DEPEND="${RDEPEND}
app-arch/unzip"

S=${WORKDIR}

PATCHES=(
"${FILESDIR}"/${P}-Makefile.patch
)

src_unpack() {
unpack simutrans-src-${MY_PV}.zip
unpack simupak64-${MY_PV/3/2}.zip

# Bundled text files are incomplete, bug #580948
cd "${S}/simutrans/text" || die
unpack language_pack-Base+texts.zip
}

src_prepare() {
default

strip-flags # bug #293927
echo "BACKEND=mixer_sdl
COLOUR_DEPTH=16
OSTYPE=linux
VERBOSE=1" > config.default || die

# make it look in the install location for the data
sed -i \
-e "s:argv\[0\]:\"/usr/share/${PN}/\":" \
simmain.cc || die

rm -f simutrans/{simutrans,*.txt}
}

src_install() {
newbin build/default/sim ${PN}
insinto /usr/share/${PN}
doins -r simutrans/*
dodoc documentation/*
doicon simutrans.ico
make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
}

0 comments on commit d184c16

Please sign in to comment.