Skip to content

Commit

Permalink
gnome-extra/evolution-ews: Version bump to 3.40.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Apr 30, 2021
1 parent 2b53fb4 commit d2b464f
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/evolution-ews/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST evolution-ews-3.38.4.tar.xz 651384 BLAKE2B e4f71d38ddef6347ba3c137bac2246a6f4ffb5990ac2b6d3be72549326ae579c0a0f2bf11d19ce578ea37b99d0f8613d8d6a7e2ac75b9381e3b8c96646e483fc SHA512 98c1fecfa45bb2fe8337a1da54f09ef620128e4bba28b008aab3117291f7df708e6676421f3b8514448d035f1288591e54642f1426830fca7ba0320e3f3a99fc
DIST evolution-ews-3.40.0.tar.xz 666148 BLAKE2B f8d7f6c917114e57bcc8ea93072f520069f7f183ce67ef5a5304c6721b3b9dae262ad5a2a8fc78b8ea75495f7f31f565b5db8e5bb02acaa5666ced15c0c3c5f2 SHA512 c5b0fdfbe455941444974738853a1c0346b77b96a483db8ff5b509a7c7dda90a0c1795749f3b17eeef4b3c2aceb06e51d2c5f9d784c0b6c17c78f8c37bc1c9af
DIST evolution-ews-3.40.1.tar.xz 672448 BLAKE2B ac6548c2567dd1ca303def27a21974f93d44c1175e8474bebaa6576dc63f8624c32e9357186e2c1412ca2091412b17e0f244c60919652ede55fb77e1bb384b90 SHA512 8d0477b500ee1b0c6a9527f2d63fe0b4238862425a079729478a8df880f35e6a1166d2f8f77cafa73844351f0cffe171d857366c4527770d7436d8b4ace29b99
68 changes: 68 additions & 0 deletions gnome-extra/evolution-ews/evolution-ews-3.40.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake gnome2

DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

# libical-glib currently (2020-02-29) oddly behind USE=introspection
RDEPEND="
dev-db/sqlite:3
>=dev-libs/glib-2.62:2
>=dev-libs/libical-3.0.5:0=[introspection(-)]
>=dev-libs/json-glib-1.0.4
>=dev-libs/libmspack-0.4
dev-libs/libxml2:2
>=gnome-extra/evolution-data-server-${PV}:0=
>=mail-client/evolution-${PV}:2.0
>=net-libs/libsoup-2.58:2.4
>=x11-libs/gtk+-3.10:3
"
DEPEND="${RDEPEND}
test? ( net-libs/uhttpmock )
"
BDEPEND="
dev-util/gdbus-codegen
dev-util/glib-utils
>=dev-util/intltool-0.35.5
>=sys-devel/gettext-0.18.3
virtual/pkgconfig
"

# Unittests fail to find libevolution-ews.so
RESTRICT="test !test? ( test )"

# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
# call; if needed, set them after cmake_src_prepare call, if that works
src_prepare() {
cmake_src_prepare
gnome2_src_prepare
}

src_configure() {
local mycmakeargs=(
-DWITH_MSPACK=ON
-DENABLE_TESTS=$(usex test)
)
cmake_src_configure
}

src_compile() {
cmake_src_compile
}

src_test() {
cmake_src_test
}

src_install() {
cmake_src_install
}

0 comments on commit d2b464f

Please sign in to comment.