Skip to content

Commit

Permalink
games-util/ucon64: port to EAPI 7, eutils--
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 4, 2021
1 parent 0777edf commit d31cfe5
Show file tree
Hide file tree
Showing 3 changed files with 27 additions and 23 deletions.
4 changes: 2 additions & 2 deletions games-util/ucon64/files/ucon64-2.0.0-ovflfix.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- backup/lynxit.c.old 2010-11-04 09:07:18.000000000 +0100
+++ backup/lynxit.c 2010-11-04 09:08:17.000000000 +0100
--- a/backup/lynxit.c
+++ b/backup/lynxit.c
@@ -561,7 +561,7 @@
return FALSE;
}
Expand Down
16 changes: 8 additions & 8 deletions games-util/ucon64/files/ucon64-2.0.0-zlib.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- misc/unzip.h.old 2011-09-23 19:53:09.708884325 +0200
+++ misc/unzip.h 2011-09-23 19:54:00.012878355 +0200
--- a/misc/unzip.h
+++ b/misc/unzip.h
@@ -49,6 +49,10 @@
#include "zlib.h"
#endif
Expand All @@ -11,8 +11,8 @@
#if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
/* like the STRICT of WIN32, we define a pointer that cannot be converted
from (void*) without cast */
--- libdiscmage/unzip.h.old 2011-09-23 19:59:47.319837133 +0200
+++ libdiscmage/unzip.h 2011-09-23 20:00:07.230834769 +0200
--- a/libdiscmage/unzip.h
+++ b/libdiscmage/unzip.h
@@ -48,6 +48,9 @@
#ifndef _ZLIB_H
#include "zlib.h"
Expand All @@ -23,8 +23,8 @@

#if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
/* like the STRICT of WIN32, we define a pointer that cannot be converted
--- libdiscmage/misc_z.c.old 2012-03-19 08:39:41.975022496 +0100
+++ libdiscmage/misc_z.c 2012-03-19 08:40:13.109803301 +0100
--- a/libdiscmage/misc_z.c
+++ b/libdiscmage/misc_z.c
@@ -27,6 +27,7 @@
#include <string.h>
#include <errno.h>
Expand All @@ -33,8 +33,8 @@
#include <zlib.h>
#include "misc_z.h"
#include "misc.h"
--- misc/archive.c.old 2012-03-19 08:41:06.478999810 +0100
+++ misc/archive.c 2012-03-19 08:41:24.134741668 +0100
--- a/misc/archive.c
+++ b/misc/archive.c
@@ -27,6 +27,7 @@
#include <string.h>
#include <errno.h>
Expand Down
30 changes: 17 additions & 13 deletions games-util/ucon64/ucon64-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,26 +1,25 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils
EAPI=7

DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
HOMEPAGE="http://ucon64.sourceforge.net/"
SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
S="${WORKDIR}"/${P}-src/src

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=""
DEPEND=""

S=${WORKDIR}/${P}-src/src
PATCHES=(
"${FILESDIR}"/${P}-ovflfix.patch
"${FILESDIR}"/${P}-zlib.patch
)

src_prepare() {
epatch "${FILESDIR}"/${P}-ovflfix.patch \
"${FILESDIR}"/${P}-zlib.patch
default

sed -i \
-e "/^CFLAGS/s/-O3/${CFLAGS}/" \
-e "/^LDFLAGS/s/-s$/${LDFLAGS}/" \
Expand All @@ -30,7 +29,7 @@ src_prepare() {
src_configure() {
local myconf

if [[ ! -e /usr/include/sys/io.h ]] ; then
if [[ ! -e "${ESYSROOT}"/usr/include/sys/io.h ]] ; then
ewarn "Disabling support for parallel port"
myconf="${myconf} --disable-parallel"
fi
Expand All @@ -41,8 +40,13 @@ src_configure() {
src_install() {
dobin ucon64
dolib.so libdiscmage/discmage.so
cd ..
dohtml -x src -r -A png,jpg *

cd .. || die

docinto html
dodoc *.html
docinto html/images
dodoc images/*
}

pkg_postinst() {
Expand Down

0 comments on commit d31cfe5

Please sign in to comment.