Skip to content

Commit

Permalink
dev-ros/console_bridge_vendor: initial import
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Dec 12, 2019
1 parent 2f7dd08 commit d37223c
Show file tree
Hide file tree
Showing 4 changed files with 104 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/console_bridge_vendor/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST console_bridge_vendor-1.2.0.tar.gz 5640 BLAKE2B d0a2b18c8d4b9259e6c8ba2953a7650e9aaef348345c5651b5a769ec9c2d4346e404688d7e6c60c3c45186d0afa0e3d3a6d9e49baef2ef1da4e0679aa7d5ba06 SHA512 2b5c8ab47554d724665184ae4dfea32a6291d9d2578a489eb81e695cc513c723e934c1dca0e66eaf83b81d656fbc67a4c7e3b4d15eae5d8770ad6ebc700b6d6b
46 changes: 46 additions & 0 deletions dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7} )

inherit cmake-utils python-r1

if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
SRC_URI=""
else
SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi

DESCRIPTION="Wrapper around console_bridge"
HOMEPAGE="https://github.com/ros2/console_bridge_vendor"

LICENSE="Apache-2.0 BSD"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE=""

DEPEND="
>=dev-libs/console_bridge-0.4.1
"
RDEPEND="${DEPEND}"
BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
${PYTHON_DEPS}
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_configure() {
# This is a build tool that does not install python-related files
# ... but we need to propagate the deps and use python3 to build it.
local pyimpl="${PYTHON_COMPAT[0]}"
python_export "${pyimpl}" EPYTHON PYTHON
python_wrapper_setup
cmake-utils_src_configure
}
46 changes: 46 additions & 0 deletions dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7} )

inherit cmake-utils python-r1

if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
SRC_URI=""
else
SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi

DESCRIPTION="Wrapper around console_bridge"
HOMEPAGE="https://github.com/ros2/console_bridge_vendor"

LICENSE="Apache-2.0 BSD"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE=""

DEPEND="
>=dev-libs/console_bridge-0.4.1
"
RDEPEND="${DEPEND}"
BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
${PYTHON_DEPS}
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

src_configure() {
# This is a build tool that does not install python-related files
# ... but we need to propagate the deps and use python3 to build it.
local pyimpl="${PYTHON_COMPAT[0]}"
python_export "${pyimpl}" EPYTHON PYTHON
python_wrapper_setup
cmake-utils_src_configure
}
11 changes: 11 additions & 0 deletions dev-ros/console_bridge_vendor/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
<remote-id type="github">ros2/console_bridge_vendor</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit d37223c

Please sign in to comment.