Skip to content

Commit

Permalink
dev-games/clanlib: tidy up patches, respect ${PKG_CONFIG}
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 19, 2021
1 parent a124396 commit d41b7a9
Show file tree
Hide file tree
Showing 9 changed files with 21 additions and 36 deletions.
6 changes: 4 additions & 2 deletions dev-games/clanlib/clanlib-2.3.7-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@

EAPI=7

inherit autotools
inherit autotools toolchain-funcs

MY_P=ClanLib-${PV}
DESCRIPTION="multi-platform game development library"
DESCRIPTION="Multi-platform game development library"
HOMEPAGE="http://www.clanlib.org/"
SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
S="${WORKDIR}"/${MY_P}
Expand Down Expand Up @@ -83,6 +83,8 @@ src_configure() {
|| use mikmod \
|| myeconfargs+=( --disable-clanSound )

tc-export PKG_CONFIG

econf "${myeconfargs[@]}"
}

Expand Down
7 changes: 5 additions & 2 deletions dev-games/clanlib/clanlib-4.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools
inherit autotools toolchain-funcs

MY_PN=ClanLib

Expand Down Expand Up @@ -60,6 +60,9 @@ src_configure() {
$(use_enable ipv6 getaddr)
$(use_enable static-libs static)
)

tc-export PKG_CONFIG

econf "${myeconfargs[@]}"
}

Expand Down
2 changes: 0 additions & 2 deletions dev-games/clanlib/files/clanlib-0.8.1-docbuilder.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,3 @@
diff --git a/Documentation/Utilities/webbuilder.pl.in b/Documentation/Utilities/webbuilder.pl.in
index ea9de63..c000432 100644
--- a/Documentation/Utilities/webbuilder.pl.in
+++ b/Documentation/Utilities/webbuilder.pl.in
@@ -68,11 +68,7 @@ sub convert
Expand Down
15 changes: 6 additions & 9 deletions dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp
--- ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp 2009-08-01 18:15:44.000000000 +0200
+++ ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp 2009-08-01 18:08:55.000000000 +0200
--- a/Sources/GL/canvas_opengl.cpp
+++ b/Sources/GL/canvas_opengl.cpp
@@ -48,6 +48,7 @@
#include "graphic_context_opengl.h"
#include "surface_target_opengl.h"
Expand All @@ -9,9 +8,8 @@ diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/

/////////////////////////////////////////////////////////////////////////////
// CL_Canvas_OpenGL construction:
diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp
--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:17:25.000000000 +0200
+++ ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:11:23.000000000 +0200
--- a/Sources/GL/GLX/input_device_linuxevent.cpp
+++ b/Sources/GL/GLX/input_device_linuxevent.cpp
@@ -35,6 +35,7 @@
#include <iostream>
#include <errno.h>
Expand All @@ -20,9 +18,8 @@ diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-

#include "API/Core/System/error.h"
#include "API/Core/System/clanstring.h"
diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp
--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:17:41.000000000 +0200
+++ ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:12:56.000000000 +0200
--- a/Sources/GL/GLX/input_device_xinput.cpp
+++ b/Sources/GL/GLX/input_device_xinput.cpp
@@ -29,6 +29,7 @@

#include <iostream>
Expand Down
4 changes: 2 additions & 2 deletions dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- ./Sources/Core/IOData/Generic/inputsource_file.cpp.orig 2012-12-30 01:49:01.698950614 +0400
+++ ./Sources/Core/IOData/Generic/inputsource_file.cpp 2012-12-30 01:49:27.714977456 +0400
--- a/Sources/Core/IOData/Generic/inputsource_file.cpp
+++ b/Sources/Core/IOData/Generic/inputsource_file.cpp
@@ -32,6 +32,7 @@
#ifdef WIN32
#include <direct.h>
Expand Down
8 changes: 0 additions & 8 deletions dev-games/clanlib/files/clanlib-0.8.1-llvm.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,3 @@
diff --git a/Sources/Display/graphic_context.cpp b/Sources/Display/graphic_context.cpp
index 42545ea..52220e2 100644
--- a/Sources/Display/graphic_context.cpp
+++ b/Sources/Display/graphic_context.cpp
@@ -237,18 +237,18 @@ void CL_GraphicContext::fill_triangle(
Expand Down Expand Up @@ -33,8 +31,6 @@ index 42545ea..52220e2 100644

params.count = 1;
params.vertices = vertice_array;
diff --git a/Sources/GL/graphic_context_opengl.cpp b/Sources/GL/graphic_context_opengl.cpp
index 78bc87d..68da072 100644
--- a/Sources/GL/graphic_context_opengl.cpp
+++ b/Sources/GL/graphic_context_opengl.cpp
@@ -355,8 +355,8 @@ void CL_GraphicContext_OpenGL::draw_quad(const CL_Quad &quad, const CL_Color &co
Expand All @@ -59,8 +55,6 @@ index 78bc87d..68da072 100644
int tx[4] = { quad.x1, quad.x2, quad.x3, quad.x4 };
int ty[4] = { quad.y1, quad.y2, quad.y3, quad.y4 };

diff --git a/Sources/SDL/graphic_context_sdl.cpp b/Sources/SDL/graphic_context_sdl.cpp
index 8093e03..c15b399 100644
--- a/Sources/SDL/graphic_context_sdl.cpp
+++ b/Sources/SDL/graphic_context_sdl.cpp
@@ -410,7 +410,7 @@ void CL_GraphicContext_SDL::update_cliprect()
Expand All @@ -72,8 +66,6 @@ index 8093e03..c15b399 100644
SDL_SetClipRect(SDL_GetVideoSurface(),&crect);
}
}
diff --git a/Sources/SDL/surface_sdl.cpp b/Sources/SDL/surface_sdl.cpp
index ff6e36f..532db84 100644
--- a/Sources/SDL/surface_sdl.cpp
+++ b/Sources/SDL/surface_sdl.cpp
@@ -259,13 +259,13 @@ void CL_Surface_SDL::draw(
Expand Down
5 changes: 2 additions & 3 deletions dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
Original file line number Diff line number Diff line change
Expand Up @@ -8,9 +8,8 @@ rather than a debug version is built (-DNDEBUG).
This patch adds the missing declaration, thus make the
file compile with or without -DNDEBUG.

diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
--- a/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
+++ b/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
--- a/Sources/Core/System/Unix/init_linux.cpp
+++ b/Sources/Core/System/Unix/init_linux.cpp
@@ -52,6 +52,7 @@
_begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ https://bugs.gentoo.org/764902
CLANLIB_CHECK_LIB(png, [`cat $srcdir/Setup/Tests/png.cpp`], clanDisplay, [ *** Cannot find png (See http://www.libpng.org ) (Try libpng12-dev or better) ], [-lz -lpng])
CLANLIB_CHECK_LIB(jpeg, [`cat $srcdir/Setup/Tests/jpeg.cpp`], clanDisplay, [ *** Cannot find jpeg (See http://www.ijg.org ) (Try libjpeg62-dev or better) ], [ -ljpeg])
- CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`freetype-config --libs` ], [ `freetype-config --cflags`])
+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`pkg-config --libs freetype2` ], [ `pkg-config --cflags freetype2`])
+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`${PKG_CONFIG} --libs freetype2` ], [ `${PKG_CONFIG} --cflags freetype2`])

dnl Optional linux/joystick.h
AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
Original file line number Diff line number Diff line change
Expand Up @@ -5,20 +5,14 @@ Subject: [PATCH] Use pkg-config to find freetype.

As of freetype-2.9.1 the freetype-config file no longer gets installed
by default.
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 6b9def916..c97e959f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,7 +307,7 @@ echo ""
if test "$enable_clanDisplay" != "no"; then
echo "Checking for clanDisplay stuff"
echo "=============================="
- CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`freetype-config --libs` ], [ `freetype-config --cflags`])
+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`pkg-config --libs freetype2` ], [ `pkg-config --cflags freetype2`])
+ CLANLIB_CHECK_LIB(ttf, [`cat $srcdir/Setup/Unix/Tests/ttf.cpp`], clanDisplay, [ *** Cannot find ttf (freetype) (See http://freetype.sourceforge.net ) (Try libfreetype6-dev or better) ], [`${PKG_CONFIG} --libs freetype2` ], [ `${PKG_CONFIG} --cflags freetype2`])

dnl Optional linux/joystick.h
AC_CHECK_HEADERS(linux/joystick.h, has_linux_joystick=yes)
Expand Down

0 comments on commit d41b7a9

Please sign in to comment.