Skip to content

Commit

Permalink
dev-php/PEAR-Crypt_CHAP: Revbump for EAPI and updated dependencies
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Jun 14, 2019
1 parent a016dd4 commit d43cdc0
Showing 1 changed file with 29 additions and 0 deletions.
29 changes: 29 additions & 0 deletions dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit php-pear-r2

DESCRIPTION="Generating CHAP packets"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"
# Crypt_CHAP_MSv1 needs mcrypt which is gone in 7.2+
RDEPEND="|| ( ( dev-php/pecl-mcrypt >=dev-lang/php-7.2:*[hash(+)] )
<dev-lang/php-7.2:*[crypt,hash]
)"
DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
PATCHES=( "${FILESDIR}/CHAP-1.5.0-constructor.patch" )

src_install() {
php-pear-r2_src_install
insinto /usr/share/php/Crypt
doins CHAP.php
}

src_test() {
pear run-tests tests/Crypt_CHAP.phpt || die
}

0 comments on commit d43cdc0

Please sign in to comment.