Skip to content

Commit

Permalink
mate-base/mate-menus: Version bump to 1.18.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
mudler committed Jun 4, 2017
1 parent 0fb2e69 commit d4759be
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-base/mate-menus/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mate-menus-1.12.0.tar.xz 342488 SHA256 b0b735be91cca632d7c63f254a9442201608b24f1d5588a1ff05b50da41b95c4 SHA512 12788d5b88c1dba7b561a3119e311a9724629d1f9ae7d54a9e4443946b331c532310c79b7b39bcacc791697ac52d4b55338051da66c4d747c371575a03183ba6 WHIRLPOOL ec1137ea30f36537dda4aa6d6432f6712a644fa942b618f83a069c8dcdf357b3106e2db6aea86a3dce19f66c053b4fb6e780143e4eab0f42e4eb246bdda29981
DIST mate-menus-1.14.0.tar.xz 362136 SHA256 26585cafa82496e22851fd7c767260797eb029d24698ca8059ddfe3f70226cc5 SHA512 9d82737669b37e85ab76e94e84a464d7cafb837b71d6af90cf08b4286480de901e1a37d279ba7f0af25e655c3c9c67481b1394587b6aad902a284a8ac58559c6 WHIRLPOOL ac0a45e91ab619c40ba946624de68f71a6df8dec7c83562fa471018f7be113aa2ac9cbb9e74d44929923c3595bb0f4756d4f9458cb5f2572864ecc5e90a5fab6
DIST mate-menus-1.16.0.tar.xz 356832 SHA256 85d51e02cd94f33b13265ba4847e93d99cef5ec3ce7ee4499958f3afe3013c33 SHA512 c6cc3ce73dfdcbe7db4a10c68d1acc5c8433f077576d047b2c3488716ff40733ae86b50480abd5c4fa033275d6f6a04dbe4c6e049a4be85fd132e8291b0d97b5 WHIRLPOOL ea606d03462e2b93b6d36de78fce39486f4f88e585640e20dd4b59e567489dd7e5d83e55e46ccd260352ed07fb27f319dfdb415a1988723954514863c6443d2f
DIST mate-menus-1.18.0.tar.xz 358032 SHA256 f07cdb952934b732678ed37a9cd740c8860e9e2d0ddb4d73a8d06cdccfc87e16 SHA512 0c9d8162f67208cecead4e2dcaf4eddf63b10484396e1b28381d98607de007c5aaf1126f36400183d8545ea21c6273f5df48b4f47847fba2470d92d9943a123b WHIRLPOOL 75a159c09e6b290934db760347ffaa22adefbc5cafbff8704e1227cfa68438a8acaaa51fda28dffbf1f67f07ee1c256e69d8ea4ee307fe9d16f9520e20d69b82
74 changes: 74 additions & 0 deletions mate-base/mate-menus/mate-menus-1.18.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )

inherit python-r1 mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
LICENSE="GPL-2 LGPL-2"
SLOT="0"

IUSE="debug +introspection python"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

COMMON_DEPEND=">=dev-libs/glib-2.36.0:2
virtual/libintl:0
introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
python? (
dev-python/pygtk:2[${PYTHON_USEDEP}]
${PYTHON_DEPS}
)"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40:*
sys-devel/gettext:*
virtual/pkgconfig:*"

src_prepare() {
mate_src_prepare
use python && python_copy_sources
}

src_configure() {
# Do NOT compile with --disable-debug/--enable-debug=no as it disables API
# usage checks.
mate_py_cond_func_wrap mate_src_configure \
--enable-debug=$(usex debug yes minimum) \
$(use_enable python) \
$(use_enable introspection)
}

src_compile() {
mate_py_cond_func_wrap default
}

src_test() {
mate_py_cond_func_wrap emake check
}

src_install() {
mate_py_cond_func_wrap mate_src_install

exeinto /etc/X11/xinit/xinitrc.d/
doexe "${FILESDIR}/10-xdg-menu-mate"
}

pkg_postinst() {
mate_pkg_postinst
einfo "Due to upstream bug"
einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
einfo "it is highly recommended to run the following command"
einfo "once you have logged in to your desktop for the first time:"
einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
}

0 comments on commit d4759be

Please sign in to comment.