forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/bcg729: Version 4.3.0_beta
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Jeroen Roovers <[email protected]>
- Loading branch information
Jeroen Roovers
committed
Nov 30, 2019
1 parent
88d096b
commit d4c1662
Showing
3 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST bcg729-1.0.4.tar.gz 115641 BLAKE2B 5240fc10f8c4c32d9c9a6fc527a198fc896a8ff5ea12aa8a692808877582ac25b3fee122799cb7f6cea58db2f07cc07348da36d9f526e62f0bf62d61ef33bcfa SHA512 fdbbd2c9a807ed832ac3976301843bae854368ab281d16f792550bbda921d226fc6003c0a499561529f22eae08bc0d78b8826c2d06c859ab706d999a96967ffb | ||
DIST bcg729-4.3.0_beta.tar.gz 121655 BLAKE2B 7501b5189b07404d49c3eb0c4bcf7789a88335ec52d172f08104bd15f1a243dab4d7ad522b1a9030942534c26b1affa278263f782c5f9ce7c140a88970790646 SHA512 5523f3fc0ec730c3e20659fe268f9ea0b676807129ca21b9492d41ea2d450526dcc297005b723438c8c20e787319ba3d1c9bf62a263b88779aa1d1243de8b13c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit cmake-utils | ||
|
||
DESCRIPTION="encoder and decoder of the ITU G729 Annex A/B speech codec" | ||
HOMEPAGE="https://github.com/BelledonneCommunications/bcg729" | ||
SRC_URI="${HOMEPAGE}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~x86" | ||
IUSE="static-libs" | ||
RDEPEND=" | ||
!media-plugins/mediastreamer-bcg729 | ||
" | ||
S=${WORKDIR}/${P/_/-} | ||
PATCHES=( | ||
"${FILESDIR}"/${PN}-4.3.0_beta-cmake-build.patch | ||
) | ||
|
||
src_configure() { | ||
mycmakeargs=( | ||
-DENABLE_STATIC=$(usex static-libs) | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
find "${ED}" -name '*.la' -delete || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -119,5 +119,3 @@ | ||
DESTINATION ${CONFIG_PACKAGE_LOCATION} | ||
) | ||
|
||
-add_subdirectory(build) | ||
- |