Skip to content

Commit

Permalink
dev-db/etcd: Version bump to 3.4.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.75, Repoman-2.3.16
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
mrueg committed Sep 2, 2019
1 parent f99b14c commit d4c90f4
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/etcd/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST etcd-3.3.13.tar.gz 3372732 BLAKE2B 241dee0d9843eefc9aaefb35be8f649d242ab1417456cc3028c8eb2ff2af6a7a1c396f04029d87877d384247b8c7a51ec6ea2e0dd51af07ce48ecc91c613c380 SHA512 5b8cf9d8d8b0afd1551f414480f04837668729c10d5d81c5e9ffba3392bd2567f3798267c5e4dbe60f49dbdd859f668c6fe0d7924e0fd65f918ab3bd01d5751a
DIST etcd-3.3.14.tar.gz 6342437 BLAKE2B 4bcf27829045e2f2f34c7628d6ed854a7ef5e6db02bd794d1135bb901486d8f3c1bf598c230fe7491e9db7273d3e5aa83bf4c941476ad3093423c14f377513b2 SHA512 76c8147168030310f0e4fa0c22670fd73369795ab6d98c0632c87b5947acf10af4adae58b46f042a482dc7a002044cfbdfbec962517018e2fdf211c381281dae
DIST etcd-3.3.15.tar.gz 6271373 BLAKE2B 85786a2a4acaf144f80461a56775b8c91164e8f0c0034ef0741d98383ac400720ca69b855588a076dc174364330c0e12df73a36570983138e33a32cdbe69e22f SHA512 9fbc02c4aacb000335d558e9c5d4df672194d1b1b8511918efa35a6123bcd7f1a06ecc527f7ff01af7c7f0e818b4809918e640fd596ec51898bf511849f0a2c5
DIST etcd-3.4.0.tar.gz 8931860 BLAKE2B abeb78866b751a3a124f1aaba2b6709402a51d0c5f36a45c8386816e4059172206c7e3420865209a53cecf7452a8c8b510a6fd50b5c7a9fefaac577e5d3c4413 SHA512 8e130cc76a2284c98bb72e3832e10e25e45c6fbaa5da7c6a7a2dd14a069d4fea7659b13c1450b87b869e5936bdad47606d0c65292febb7257369531ff2658674
78 changes: 78 additions & 0 deletions dev-db/etcd/etcd-3.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit user systemd golang-vcs-snapshot

KEYWORDS="~amd64"
EGO_PN="go.etcd.io/etcd"
GIT_COMMIT="898bd13"
MY_PV="${PV/_rc/-rc.}"
DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
HOMEPAGE="https://github.com/etcd-io/etcd"
SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="doc +server"
DEPEND=">=dev-lang/go-1.12:="
RDEPEND="!dev-db/etcdctl"

src_prepare() {
default
sed -e "s|GIT_SHA=.*|GIT_SHA=${GIT_COMMIT}|"\
-i "${S}"/src/${EGO_PN}/build || die
sed -e 's:\(for p in \)shellcheck :\1 :' \
-e 's:^ gofmt \\$:\\:' \
-e 's:^ govet \\$:\\:' \
-i "${S}"/src/${EGO_PN}/test || die
# missing ... in args forwarded to print-like function
sed -e 's:l\.Logger\.Panic(v):l.Logger.Panic(v...):' \
-i "${S}"/src/${EGO_PN}/raft/logger.go || die
}

pkg_setup() {
if use server; then
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
fi
}

src_compile() {
export -n GOCACHE XDG_CACHE_HOME #651934
export GOPATH=${S}
pushd src/${EGO_PN} || die
GO_BUILD_FLAGS=-v ./build || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin bin/etcdctl
use doc && dodoc -r Documentation
if use server; then
insinto /etc/${PN}
doins "${FILESDIR}/${PN}.conf"
dobin bin/etcd
dodoc README.md
systemd_dounit "${FILESDIR}/${PN}.service"
systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
keepdir /var/lib/${PN}
fowners ${PN}:${PN} /var/lib/${PN}
fperms 0700 /var/lib/${PN}
keepdir /var/log/${PN}
fowners ${PN}:${PN} /var/log/${PN}
fperms 755 /var/log/${PN}
fi
popd || die
}

src_test() {
pushd src/${EGO_PN} || die
GO111MODULES=off ./test || die
popd || die
}

0 comments on commit d4c90f4

Please sign in to comment.