Skip to content

Commit

Permalink
sys-devel/kgcc64: Version 9.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Sep 3, 2019
1 parent d21c18d commit d5549cb
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
2 changes: 2 additions & 0 deletions sys-devel/kgcc64/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -40,3 +40,5 @@ DIST gcc-8.3.0-patches-1.0.tar.bz2 12278 BLAKE2B 793465c5de0af850c7f3017b3011e68
DIST gcc-8.3.0.tar.xz 63694700 BLAKE2B 71df2ff5bd6874d57519c2e9af6b22152c8c4d7fab906a5f427b41bc4e8e742127592a8684120d9d3c9ce6241439531850be08ec0a4f29dbfdee95435655fdca SHA512 1811337ae3add9680cec64968a2509d085b6dc5b6783fc1e8c295e3e47416196fd1a3ad8dfe7e10be2276b4f62c357659ce2902f239f60a8648548231b4b5802
DIST gcc-9.1.0-patches-1.1.tar.bz2 13931 BLAKE2B 55e863514f41f1af11b1f6f618604edf7f173b4c4ef8df1301ccaf4577355ed03a34b04ab50a6cf4e50317b7f047f279e4212215b183d0642f138ee5163f655d SHA512 ab850bd38902c52586fc84dd1b2da31bab857412db08dce96642f17f213c95bae029bb1be5e0ac4bb12e55f863ecfc2ccda67635e8bc7b54383b2813642d991d
DIST gcc-9.1.0.tar.xz 70546856 BLAKE2B 0f7e5575aebc24113d12a56eb3dbf4bcdba3c656a76513c44dbbcded9ee71629727f24949bf2e1424682a9e5eda7c51eed93317e6f80013f5a837aaf25b82805 SHA512 b6134df027e734cee5395afd739fcfa4ea319a6017d662e54e89df927dea19d3fff7a6e35d676685383034e3db01c9d0b653f63574c274eeb15a2cb0bc7a1f28
DIST gcc-9.2.0-patches-1.tar.bz2 12836 BLAKE2B c29516d2877229129cc69ebb781198918f0e59e2a4631f3b2933b5a6db61d50ef0d2e78ee9acaaf1c50c597aad3203d81e49d4e0674f7ac74bdedc401238940b SHA512 0382ed0d483955079bd20fc15066b8f45772651bcba83dbed2c35e51f7259cfd28b825243c6a49a0bf51d9ab1eacec3cf55c47a00d2873d6122d32b9fc05d87c
DIST gcc-9.2.0.tar.xz 70607648 BLAKE2B 41a5e148f9a6857d6599679964c203533f76f330ad527fbe7c5e746d78f6f6f6d6d0f330a67cb1e794e155be8d1cd6e986bcc8a116d620dca410b78f0bcdd453 SHA512 a12dff52af876aee0fd89a8d09cdc455f35ec46845e154023202392adc164848faf8ee881b59b681b696e27c69fd143a214014db4214db62f9891a1c8365c040
47 changes: 47 additions & 0 deletions sys-devel/kgcc64/kgcc64-9.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
mips*) CTARGET=${CHOST/mips/mips64};;
powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
s390*) CTARGET=${CHOST/s390/s390x};;
sparc*) CTARGET=${CHOST/sparc/sparc64};;
i?86*) CTARGET=x86_64-${CHOST#*-};;
esac
export CTARGET
TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true

PATCH_VER="1"
inherit toolchain

DESCRIPTION="64bit kernel compiler"

# Works on hppa and mips; all other archs, refer to bug #228115
KEYWORDS="~hppa ~mips"

# unlike every other target, hppa has not unified the 32/64 bit
# ports in binutils yet
DEPEND="
hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-hppa64
!sys-devel/gcc-mips64
!sys-devel/gcc-powerpc64
!sys-devel/gcc-sparc64"

pkg_postinst() {
toolchain_pkg_postinst

cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
cat <<-EOF >${CTARGET%%-*}-linux-${x}
#!/bin/sh
exec ${CTARGET}-${x} "\$@"
EOF
chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}

0 comments on commit d5549cb

Please sign in to comment.