Skip to content

Commit

Permalink
kde-misc/basket: Fix xdg-mime file installation and drop bogus code
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/699960
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 14, 2019
1 parent 1ef3822 commit d58bb66
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
2 changes: 2 additions & 0 deletions kde-misc/basket/basket-2.49b.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -54,6 +54,8 @@ DEPEND="${RDEPEND}
$(add_qt_dep qtconcurrent)
"

PATCHES=( "${FILESDIR}/${P}-xdg_mime_install_dir.patch" )

src_prepare() {
kde5_src_prepare
if ! use test; then
Expand Down
35 changes: 35 additions & 0 deletions kde-misc/basket/files/basket-2.49b-xdg_mime_install_dir.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 4c80df2dd6aeb7a90677d983a292e4f9a95f2a70 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Thu, 14 Nov 2019 13:35:42 +0100
Subject: [PATCH] Fix install basket.xml to XDG_MIME_INSTALL_DIR

Previous code did not work at all in a sandboxed packaging build.
---
file-integration/CMakeLists.txt | 14 ++------------
1 file changed, 2 insertions(+), 12 deletions(-)

diff --git a/file-integration/CMakeLists.txt b/file-integration/CMakeLists.txt
index c3774fe..77e4692 100644
--- a/file-integration/CMakeLists.txt
+++ b/file-integration/CMakeLists.txt
@@ -11,15 +11,5 @@ install(TARGETS basketthumbcreator DESTINATION ${PLUGIN_INSTALL_DIR})

########### install files ###############

-find_program(XDG-MIME_EXECUTABLE xdg-mime)
-find_program(XDG-DESKTOP-MENU_EXECUTABLE xdg-desktop-menu)
-
-install(FILES basketthumbcreator.desktop DESTINATION ${SERVICES_INSTALL_DIR})
-install(CODE "
-execute_process(COMMAND ${XDG-MIME_EXECUTABLE} install --novendor
- ${CMAKE_CURRENT_SOURCE_DIR}/basket.xml)
-execute_process(COMMAND ${XDG-DESKTOP-MENU_EXECUTABLE} install
- --novendor ${CMAKE_SOURCE_DIR}/src/basket.desktop)
-execute_process(COMMAND ${XDG-MIME_EXECUTABLE} default
- ${CMAKE_SOURCE_DIR}/src/basket.desktop application/x-basket-item)
-")
+install(FILES basketthumbcreator.desktop DESTINATION ${SERVICES_INSTALL_DIR})
+install(FILES basket.xml DESTINATION ${XDG_MIME_INSTALL_DIR})
--
2.24.0

0 comments on commit d58bb66

Please sign in to comment.