Skip to content

Commit

Permalink
games-board/phalanx: EAPI8, minor improvements
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.23, Repoman-3.0.3
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Closes: gentoo#22378
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
mm1ke authored and ionenwks committed Sep 24, 2021
1 parent 7963aaf commit d5a9e8f
Showing 1 changed file with 10 additions and 11 deletions.
21 changes: 10 additions & 11 deletions games-board/phalanx/phalanx-22-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,30 +1,27 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=8

inherit toolchain-funcs

MY_PN="Phalanx"
MY_PV="XXII"
MY_P="${MY_PN}-${MY_PV}"
MY_P="${PN^}-XXII"

DESCRIPTION="A chess engine suitable for beginner and intermediate players"
DESCRIPTION="Chess engine suitable for beginner and intermediate players"
HOMEPAGE="http://phalanx.sourceforge.net/"
SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"

LICENSE="GPL-2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

S="${WORKDIR}/${MY_P}"

src_compile() {
# configure is not used in the project; confs are in Makefile,
# and here we override them:
local define="-DGNUFUN" myvar
for myvar in "PBOOK" "SBOOK" "LEARN" ; do
define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
define="${define} -D${myvar}_DIR=\"\\\"${EPREFIX}/usr/share/${PN}\\\"\""
done
emake \
DEFINES="${define}" \
Expand All @@ -35,7 +32,9 @@ src_compile() {

src_install() {
dobin phalanx

insinto /usr/share/${PN}
doins pbook.phalanx sbook.phalanx learn.phalanx

einstalldocs
}

0 comments on commit d5a9e8f

Please sign in to comment.