Skip to content

Commit

Permalink
games-puzzle/flobopuyo: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed May 1, 2018
1 parent ebe8e39 commit d5c6a2f
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 2 deletions.
4 changes: 2 additions & 2 deletions games-puzzle/flobopuyo/files/flobopuyo-0.20-libs.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.orig 2004-10-08 18:41:12.000000000 -0400
+++ Makefile 2008-08-06 19:48:47.000000000 -0400
--- a/Makefile.orig 2004-10-08 18:41:12.000000000 -0400
+++ b/Makefile 2008-08-06 19:48:47.000000000 -0400
@@ -41,15 +41,13 @@
##############

Expand Down
50 changes: 50 additions & 0 deletions games-puzzle/flobopuyo/flobopuyo-0.20-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop toolchain-funcs

DESCRIPTION="Clone of the famous PuyoPuyo game"
HOMEPAGE="http://www.ios-software.com/?page=projet&quoi=29"
SRC_URI="http://www.ios-software.com/flobopuyo/${P}.tgz
mirror://gentoo/${PN}.png"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE="opengl"

DEPEND="media-libs/libsdl
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer[mod]
opengl? ( virtual/opengl )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
eapply \
"${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-libs.patch

find . -type f -name ".*" -exec rm -f \{\} \;
sed -i \
-e "s:^DATADIR=.*:DATADIR=\"/usr/share/${PN}\":" \
-e "/^INSTALL_BINDIR/s:/\$(PREFIX)/games:/usr/bin:" \
Makefile \
|| die
}

src_compile() {
emake \
CXX="$(tc-getCXX)" \
ENABLE_OPENGL="$(use opengl && echo true || echo false)"
}

src_install() {
default
doman man/flobopuyo.6
doicon "${DISTDIR}/${PN}.png"
make_desktop_entry flobopuyo FloboPuyo
}

0 comments on commit d5c6a2f

Please sign in to comment.