Skip to content

Commit

Permalink
net-libs/libosip: bump EAPI and drop eutils
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
FuzzyGophers committed May 28, 2018
1 parent 067a9b1 commit d5e6d68
Showing 1 changed file with 7 additions and 9 deletions.
16 changes: 7 additions & 9 deletions net-libs/libosip/libosip-3.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,13 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="2"
EAPI=6

inherit eutils autotools
inherit autotools

MY_PV=${PV%.?}-${PV##*.}
MY_PV=${PV}
MY_P=${PN}2-${MY_PV}

DESCRIPTION="a simple way to support the Session Initiation Protocol"
HOMEPAGE="https://www.gnu.org/software/osip/"
SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
Expand All @@ -19,17 +20,14 @@ IUSE="test"

S=${WORKDIR}/${MY_P}

PATCHES=( "${FILESDIR}/${PN}-3.3.0-out-source-build.patch" )

src_prepare() {
epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
eapply_user
AT_M4DIR="scripts" eautoreconf
}

src_configure() {
econf --enable-mt \
$(use_enable test)
}

src_install() {
emake DESTDIR="${D}" install || die "Failed to install"
dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
}

0 comments on commit d5e6d68

Please sign in to comment.