Skip to content

Commit

Permalink
games-engines/renpy: version bump to 6.99.5
Browse files Browse the repository at this point in the history
X-Gentoo-Bug: 545540
X-Gentoo-Bug-url: https://bugs.gentoo.org/show_bug.cgi?id=545540
  • Loading branch information
Julian Ospald committed Aug 9, 2015
1 parent 4c6ffbb commit d6b01b6
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/renpy/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST renpy-6.16.5-source.tar.bz2 14455622 SHA256 5ecb00fa84a048ff6e1f1d8a0114373
DIST renpy-6.17.7-source.tar.bz2 17932988 SHA256 fef01de9e482b73d9d409de7a43bada6dd3e2a0549b99dd487306371190ed038 SHA512 22b0e08b18ee35317b11451205233cbd8a29617d9c3d298bbdcfc5757f67c2f0e4c8a748aa83d5c8b43786c062ffca109d07e981efa750fcee26f45f08a33ea2 WHIRLPOOL fef82eb6c958a2525797e5d8bfae3488fba606b70eeed5c94f7afcab4fa46e7a7eb43d91b4bd55f553b65a72b12236e02ecdee55e8852c1fafc055332f9d131d
DIST renpy-6.18.2-source.tar.bz2 19854257 SHA256 635c7495d5ced298183793cafbe8631981a5a75aec106b4ba145d3dd870a544c SHA512 239de63f7e015076aeb05d4f7da7caa676e151b0f3cbd710b0fe59a592f7af02cd8994ddb0d6225ccec337579eb2de1a5b83759a28572ead631fe3b5df515e8b WHIRLPOOL 85ac745891bf2ab729cb8ad44cab0cdd03399956455a4fbf73d638b87cf49d44c7395658e3882509dc0652492da931f7932297eb39974d7c890e772cfe1f13ff
DIST renpy-6.18.3-source.tar.bz2 23244450 SHA256 c0c6af79ceb529e69cebfdb0e9849e50dc27e424dc2fd2b322c13d6ec938cba6 SHA512 7ea99adaf1fbea7a499790fb5b37349fc797f383fb633956a43955c80885b259e26570469c430f4c4c103e62444f60082690489ee6400809f5e9024693261e55 WHIRLPOOL 6e4e68228bc38c709af4387f209717e4644efccae47fb04b7071783b0c01d6fbe4ca65d7c712a32e159cd59c663873457e54c3851e9e4a84d3d4e4ed05271102
DIST renpy-6.99.5-source.tar.bz2 27285400 SHA256 cec38c548a812331fe42b60882ba271ea10fb369f0ba67bad1facd8d556ae74d SHA512 0e9d3dca70924e587711effa34d5af45fcd1c1bc6ce0b38723b39e07593a85dc55645ad4cb002f43fe33f387ee58c92626004f655d0f2955c55d8d01b5453326 WHIRLPOOL f3db4a08b1216b69b2724668cb22ea3c720826a6bf82042d0783fb8048d07074fd473157132e27010570c485fc90d09cb0115accbb429aad48f62417245852a8
111 changes: 111 additions & 0 deletions games-engines/renpy/renpy-6.99.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=5
PYTHON_COMPAT=( python2_7 )
DISTUTILS_IN_SOURCE_BUILD=1
inherit eutils toolchain-funcs python-r1 versionator gnome2-utils games distutils-r1

DESCRIPTION="Visual novel engine written in python"
HOMEPAGE="http://www.renpy.org"
SRC_URI="http://www.renpy.org/dl/${PV}/${P}-source.tar.bz2"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
MYSLOT=$(delete_all_version_separators ${SLOT})
KEYWORDS="~amd64 ~x86"
IUSE="development doc examples"
REQUIRED_USE="examples? ( development )"

RDEPEND="
>=app-eselect/eselect-renpy-0.6
dev-libs/fribidi
~dev-python/pygame_sdl2-${PV}[${PYTHON_USEDEP}]
>=dev-lang/python-exec-0.3[${PYTHON_USEDEP}]
media-libs/glew
media-libs/libpng:0
media-libs/libsdl2[video]
media-libs/freetype:2
sys-libs/zlib
virtual/ffmpeg"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
virtual/pkgconfig"

S=${WORKDIR}/${P}-source

pkg_setup() {
games_pkg_setup
export CFLAGS="${CFLAGS} $($(tc-getPKG_CONFIG) --cflags fribidi)"
}

python_prepare_all() {
# wooosh! this should fix multiple abi
epatch "${FILESDIR}"/${P}-multiple-abi.patch

einfo "Deleting precompiled python files"
find . -name '*.py[co]' -print -delete || die

sed -i \
-e "s/@SLOT@/${MYSLOT}/" \
renpy.py renpy/common.py || die "setting slot failed!"

distutils-r1_python_prepare_all
}

python_compile() {
cd "${S}"/module || die
distutils-r1_python_compile
}

python_install() {
cd "${S}"/module || die
distutils-r1_python_install --install-lib="$(python_get_sitedir)/renpy${MYSLOT}"

cd "${S}" || die
python_scriptinto "${GAMES_BINDIR}"
python_newscript renpy.py ${PN}-${SLOT}

python_moduleinto renpy${MYSLOT}
python_domodule renpy
if use development ; then
python_domodule launcher templates
fi
if use examples ; then
python_domodule the_question tutorial
fi
}

python_install_all() {
if use development; then
newicon -s 32 launcher/game/images/logo32.png ${P}.png
make_desktop_entry ${PN}-${SLOT} "Ren'Py ${PV}" ${P}
fi

if use doc; then
dohtml -r doc
fi

prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
use development && gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
use development && gnome2_icon_cache_update

einfo "running: eselect renpy update --if-unset"
eselect renpy update --if-unset
}

pkg_postrm() {
use development && gnome2_icon_cache_update

einfo "running: eselect renpy update --if-unset"
eselect renpy update --if-unset
}

0 comments on commit d6b01b6

Please sign in to comment.