Skip to content

Commit

Permalink
dev-php/pecl-http: add PHP 7.3 support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jun 7, 2019
1 parent eecd3f1 commit d702110
Show file tree
Hide file tree
Showing 4 changed files with 90 additions and 16 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-http/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pecl_http-2.6.0.tgz 217673 BLAKE2B a7147924cfc018c3e273d85666d9792ea614955d0aa20ac43171266d91d139dccdbf2472dec4d145b798ce99a541dba48f7bed6009fbdf2a7ad81ab322963788 SHA512 12d18049411a4133008449a1e7458a3055322dc337f421e0e2be126ec965f15b0189af6fccd9ca4537c48819c763b9e020906ac6d09d87ead92f4436fac595ad
DIST pecl_http-3.1.0.tgz 214166 BLAKE2B 2f84fc9f5f7d465142e3482a9ee46b9dd80dd2b5ec58ad1d8d4fb18a665ebe70e4f872b8915c3a84484a3b1cd0709b39bf6170c6f1c6175aef7d43bac44aa3df SHA512 1c272aa476106bb61848f175f0ba6715b3d8928f70cdac1a673cc87c2dc780dff5434a3bc595d5e8a1ef7b847a1d2e214f9e9ae80b8b5d1f80a299febc85b0ea
DIST pecl_http-3.2.0.tgz 218829 BLAKE2B bbd6f9fe8afb4324d928496e1fbcdd455e8bff5e45312ba65e5e9263719b098763203de055ea8a8ff6202ae4a434d37db25bb0975faacc956af4a0c6e8bfe8a1 SHA512 59738ee52370c68f7e74349d52738da845cfb83ae27b51a2caf3b048ba0b37c897702d7f5f8e0517df5612fd2e904d02e8e24c9e649a9e7cfdcdc04e9d19b113
DIST pecl_http-3.2.1.tgz 221244 BLAKE2B b6581829fb8a800e24ccedd4d0f3efbaf558850bdc356d27a6e1d1097a8e2cfc61963a1daccd1d0f269a7cef5b243d45cdfaff5138321fe20df615dde44d19e3 SHA512 e67d4b32ba6f524e3fcf65f5497b94275e1a4a14fce97c57afe366369f368b3acdbedf364ed73cf983fb2c5f57f498adaa1100e7c936f11cbc5de1caedad7b51
15 changes: 7 additions & 8 deletions dev-php/pecl-http/pecl-http-3.1.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand All @@ -9,11 +9,11 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"

USE_PHP="php5-6 php7-0 php7-1 php7-2"
USE_PHP="php5-6 php7-1 php7-2"

inherit php-ext-pecl-r3

USE_PHP="php7-0 php7-1 php7-2"
USE_PHP="php7-1 php7-2"

KEYWORDS="~amd64 ~x86"

Expand All @@ -23,13 +23,12 @@ SLOT="7"
IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"

DEPEND="dev-libs/libevent
dev-php/pecl-propro:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]
dev-php/pecl-raphf:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]
dev-php/pecl-propro:7[php_targets_php7-1?,php_targets_php7-2?]
dev-php/pecl-raphf:7[php_targets_php7-1?,php_targets_php7-2?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
!ssl? ( net-misc/curl[-ssl] )
php_targets_php7-0? ( dev-lang/php:7.0[hash,session,iconv] )
php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )
php_targets_php7-2? ( dev-lang/php:7.2[hash,session,iconv] )"
RDEPEND="${DEPEND}
Expand All @@ -40,15 +39,15 @@ PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libid
PATCHES=( "${FILESDIR}/pecl-http-gnutls.patch" )

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
if use php_targets_php7-1 || use php_targets_php7-2 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
if use php_targets_php7-1 || use php_targets_php7-2 ; then
php-ext-pecl-r3_src_install
fi
}
Expand Down
15 changes: 7 additions & 8 deletions dev-php/pecl-http/pecl-http-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
Expand All @@ -9,11 +9,11 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"

USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
USE_PHP="php5-6 php7-1 php7-2 php7-3"

inherit php-ext-pecl-r3

USE_PHP="php7-0 php7-1 php7-2 php7-3"
USE_PHP="php7-1 php7-2 php7-3"

KEYWORDS="~amd64 ~x86"

Expand All @@ -24,13 +24,12 @@ IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"

DEPEND="app-arch/brotli:=
dev-libs/libevent
dev-php/pecl-propro:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]
dev-php/pecl-raphf:7[php_targets_php5-6?,php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]
dev-php/pecl-propro:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
dev-php/pecl-raphf:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
!ssl? ( net-misc/curl[-ssl] )
php_targets_php7-0? ( dev-lang/php:7.0[hash,session,iconv] )
php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )
php_targets_php7-2? ( dev-lang/php:7.2[hash,session,iconv] )
php_targets_php7-3? ( dev-lang/php:7.3[hash,session,iconv] )"
Expand All @@ -40,15 +39,15 @@ RDEPEND="${DEPEND}
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-pecl-r3_src_install
fi
}
Expand Down
75 changes: 75 additions & 0 deletions dev-php/pecl-http/pecl-http-3.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PHP_EXT_NAME="http"
PHP_EXT_PECL_PKG="pecl_http"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"

USE_PHP="php5-6 php7-1 php7-2 php7-3"

inherit php-ext-pecl-r3

USE_PHP="php7-1 php7-2 php7-3"

KEYWORDS="~amd64 ~x86"

DESCRIPTION="Extended HTTP Support for PHP"
LICENSE="BSD-2 MIT"
SLOT="7"
IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"

DEPEND="app-arch/brotli:=
dev-libs/libevent
dev-php/pecl-propro:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
dev-php/pecl-raphf:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
!ssl? ( net-misc/curl[-ssl] )
php_targets_php7-1? ( dev-lang/php:7.1[hash,session,iconv] )
php_targets_php7-2? ( dev-lang/php:7.2[hash,session,iconv] )
php_targets_php7-3? ( dev-lang/php:7.3[hash,session,iconv] )"
RDEPEND="${DEPEND}
php_targets_php5-6? ( dev-php/pecl-http:2[php_targets_php5-6] )"

PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )

src_prepare() {
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_install() {
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-pecl-r3_src_install
fi
}

src_test() {
# Cannot use eclass function due to required modules
# All tests SKIP otherwise
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
# Link in required modules for testing
ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
sed -i \
's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
Makefile || die
NO_INTERACTION="yes" emake test
# Clean up testing links
rm modules/propro.so modules/raphf.so || die
done
}

pkg_postinst() {
ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
ewarn "Please review the documentation and update your code."
}

0 comments on commit d702110

Please sign in to comment.