Skip to content

Commit

Permalink
media-libs/libplacebo: update to 1.29.0
Browse files Browse the repository at this point in the history
Signed-off-by: Niklas Haas <[email protected]>
Closes: gentoo#14086
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
haasn authored and juippis committed Dec 22, 2019
1 parent 2854120 commit d70c397
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/libplacebo/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libplacebo-v1.21.0.tar.gz 326918 BLAKE2B fe9500de23487d7d5dfc51d9f94dd3d33d22bdac3005fc3334814c53a76a46cebd40655675b5172f058d02dd865385a993b3c52a863b9e9b32ac0bc4801e0126 SHA512 5de95b8cc48ba4ec9bc3afb8c8f2c4fae0d53ce6e69ffb53884c3a3ee2580998bae46b8934e462740b6c9c2e66e3c5d5f009f9b0f8ad2cb7b4fba829891cf333
DIST libplacebo-v1.29.0.tar.gz 330474 BLAKE2B a3b183e4e1655cdf93b787d6f4962f6bdc185e729754df4c23d9052e8932991e6085286c93dcf623347f5e26371e3d56e6d9c433162ec04a0e91ef87eb46ac1c SHA512 1b0bb771a93ef68eb9a5dc4de3b31f936d45321edefc79f470005b5d7ab2f674831eea5595d2d6a009504e2df31a637d44b9103bca930a0870da78c3c9aa6fc7
55 changes: 55 additions & 0 deletions media-libs/libplacebo/libplacebo-1.29.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://code.videolan.org/videolan/libplacebo.git"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://code.videolan.org/videolan/libplacebo/-/archive/v${PV}/libplacebo-v${PV}.tar.gz"
S="${WORKDIR}/${PN}-v${PV}"
fi

inherit meson multilib-minimal

DESCRIPTION="Reusable library for GPU-accelerated image processing primitives"
HOMEPAGE="https://github.com/haasn/libplacebo"

LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="glslang lcms +shaderc test +vulkan"
REQUIRED_USE="vulkan? ( || ( glslang shaderc ) )"

RDEPEND="glslang? ( dev-util/glslang[${MULTILIB_USEDEP}] )
lcms? ( media-libs/lcms:2[${MULTILIB_USEDEP}] )
shaderc? ( >=media-libs/shaderc-2017.2[${MULTILIB_USEDEP}] )
vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

RESTRICT="!test? ( test )"

multilib_src_configure() {
local emesonargs=(
$(meson_feature glslang)
$(meson_feature lcms)
$(meson_feature shaderc)
$(meson_feature vulkan)
$(meson_use test tests)
)
meson_src_configure
}

multilib_src_compile() {
meson_src_compile
}

multilib_src_test() {
meson_src_test
}

multilib_src_install() {
meson_src_install
}

0 comments on commit d70c397

Please sign in to comment.