Skip to content

Commit

Permalink
dev-libs/Ice: use ruby23
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
graaff committed Apr 15, 2018
1 parent ac608a3 commit d737f2e
Show file tree
Hide file tree
Showing 2 changed files with 10 additions and 10 deletions.
10 changes: 5 additions & 5 deletions dev-libs/Ice/Ice-3.6.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )

RUBY_OPTIONAL="yes"
USE_RUBY="ruby22"
USE_RUBY="ruby23"

PHP_EXT_NAME="IcePHP"
PHP_EXT_INI="yes"
Expand Down Expand Up @@ -41,7 +41,7 @@ RDEPEND=">=dev-libs/expat-2.0.1
)
dev-cpp/libmcpp
python? ( ${PYTHON_DEPS} )
ruby? ( $(ruby_implementation_depend ruby22) )
ruby? ( $(ruby_implementation_depend ruby23) )
mono? ( dev-lang/mono )
php? ( dev-lang/php:7.0 )
!dev-python/IcePy
Expand Down Expand Up @@ -174,13 +174,13 @@ src_configure() {
fi

if use ruby; then
SITERUBY="$(ruby22 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
SITERUBY="$(ruby23 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
MAKE_RULES_RUBY=(
"install_rubydir=\"${ED%/}/${SITERUBY}\""
"install_libdir=\"${ED%/}/${SITERUBY}\""
)

# make it use ruby22 only
# make it use ruby23 only
sed -i \
-e 's|RUBY = ruby|\022|' \
ruby/config/Make.rules || die "sed failed"
Expand Down
10 changes: 5 additions & 5 deletions dev-libs/Ice/Ice-3.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )

RUBY_OPTIONAL="yes"
USE_RUBY="ruby22"
USE_RUBY="ruby23"

PHP_EXT_NAME="IcePHP"
PHP_EXT_INI="yes"
Expand Down Expand Up @@ -41,7 +41,7 @@ RDEPEND=">=dev-libs/expat-2.0.1
)
dev-cpp/libmcpp
python? ( ${PYTHON_DEPS} )
ruby? ( $(ruby_implementation_depend ruby22) )
ruby? ( $(ruby_implementation_depend ruby23) )
mono? ( dev-lang/mono )
php? ( dev-lang/php:7.0 )
!dev-python/IcePy
Expand Down Expand Up @@ -173,13 +173,13 @@ src_configure() {
fi

if use ruby; then
SITERUBY="$(ruby22 -r rbconfig -e 'print RbConfig::CONFIG[\"sitelibdir\"]')"
SITERUBY="$(ruby23 -r rbconfig -e 'print RbConfig::CONFIG[\"sitelibdir\"]')"
MAKE_RULES_RUBY=(
"install_rubydir=\"${ED%/}/${SITERUBY}\""
"install_libdir=\"${ED%/}/${SITERUBY}\""
)

# make it use ruby22 only
# make it use ruby23 only
sed -i \
-e 's|RUBY = ruby|\022|' \
ruby/config/Make.rules || die "sed failed"
Expand Down

0 comments on commit d737f2e

Please sign in to comment.