Skip to content

Commit

Permalink
net-misc/youtube-dl: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Jeroen Roovers committed Nov 29, 2015
1 parent 71fecd8 commit d7aef1b
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST youtube-dl-2015.04.03.tar.gz 1472296 SHA256 0521a15a24a9b620728a2f45ea9163ca74660ed443781b6e69b4e06d36d7bf59 SHA512 6b2c85cfa222a31f3462aab583fa98bb92544cd5fb0d395ca0b69a26c24ab174870d02264e058281f09305752d50aa5a06d0d747205499a530b275e3194fc6f9 WHIRLPOOL 391e06ea261f92e03a0b38618307f1c9d53a2dfb9f2062fe0cd3ded1ea0c411033a17ded581616032c74a9e4fb398a57e565bf847196a23a9f89433f861362ae
DIST youtube-dl-2015.11.15.tar.gz 1794423 SHA256 30964eeac39d4b2aafba1b117b75dcc0f30a0b52ce477bde96156aeab4b56046 SHA512 478aaff8876d4cf34f4dab9ba08c1d630bb4f295f7b5dc384b59c41ead725a1ccf7f595e2fed3ccca59fab6c46c1a99ab84edfa886f14478e768dc2213928dbe WHIRLPOOL 03f238ddfc7d95555e30e6f456a0c36eeb2354bd7c39a3ab030aec09d7d3b5bec837904dc23430df76f9814bc1433995a2a2a06ec6238a7031affd7fff490f1e
DIST youtube-dl-2015.11.21.tar.gz 1800730 SHA256 26ef30392579289ff54c54c6747fd0036a5fdf7429c55106f9703b0f9f19e339 SHA512 db872153b57cd2a397951407938d4d2f823aaf18e29216eef3b16607ccce0684a466ac9cfedb5b8f67e0f799cc849536bbfc7db82a2b3dd241e5fd91d0d106c0 WHIRLPOOL 7cc35d091ffd4cfc853339b14d93e6e7cad289e49a0c367500347d56f7187102b4549a3f741fa0eeba4c91204a3239bf0d8b96ec24ae7cb0b68e8adf43f2be54
DIST youtube-dl-2015.11.27.1.tar.gz 1803857 SHA256 35a7b2947200209bef9e642d1203e9d4a4103e279222c3ca3b5ee3adf3c8c535 SHA512 7771ed739568a52b0168e095eb97b943b82c6ee463a662f5cf94c40fce4f51ad0ca6d09c2569393b1d09568b63859b1837d247c9994c5134ad79af18bb5aa1ad WHIRLPOOL 5fedcea551ba8637773367d46f78d8e68110c993eb12eda31028b1a38bca3b9928c62ea4519da3ba70f3a7aa62948820d892d4ff3d8d38b2bd847b1348183f33
87 changes: 87 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2015.11.27.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
DISTUTILS_SINGLE_IMPL=true
inherit bash-completion-r1 distutils-r1 eutils

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="offensive test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

src_prepare() {
if ! use offensive; then
sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink drtuber eporner eroprofile extremetube
fourtube foxgay goshgay hellporno hentaistigma hornbunny keezmovies
mofosex motherless porn91 pornhd pornotube pornovoisines pornoxo
redtube sexykarma sexu sunporno slutload spankbang spankwire thisav
trutube tube8 vporn xbef xnxx xtube xvideos xxxymovies youjizz
youporn
)
# these have multi-line import statements
local mxxx=(
pornhub xhamster tnaflix
)
# do single line imports
sed -i \
-e $( printf '/%s/d;' ${xxx[@]} ) \
youtube_dl/extractor/__init__.py \
|| die

# do multiple line imports
sed -i \
-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
youtube_dl/extractor/__init__.py \
|| die

sed -i \
-e $( printf '/%s/d;' ${mxxx[@]} ) \
youtube_dl/extractor/generic.py \
youtube_dl/extractor/tumblr.py \
|| die

rm \
$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
test/test_age_restriction.py \
|| die
fi

epatch_user
}

src_compile() {
distutils-r1_src_compile
}

src_test() {
emake test
}

src_install() {
python_domodule youtube_dl
dobin bin/${PN}
dodoc README.txt
doman ${PN}.1
newbashcomp ${PN}.bash-completion ${PN}
python_fix_shebang "${ED}"
}

0 comments on commit d7aef1b

Please sign in to comment.