Skip to content

Commit

Permalink
dev-games/ode: port to EAPI 7
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 19, 2021
1 parent ec58139 commit d7d89de
Show file tree
Hide file tree
Showing 3 changed files with 93 additions and 49 deletions.
44 changes: 29 additions & 15 deletions dev-games/ode/ode-0.11.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit ltprune
EAPI=7

DESCRIPTION="Open Dynamics Engine SDK"
HOMEPAGE="http://ode.org/"
Expand All @@ -13,13 +12,19 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug doc double-precision examples gyroscopic static-libs"

RDEPEND="examples? (
RDEPEND="
examples? (
virtual/opengl
)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
)
"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

DOCS=( CHANGELOG.txt README.txt )

src_prepare() {
default

sed -i \
-e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
drawstuff/src/Makefile.in \
Expand All @@ -41,30 +46,39 @@ src_configure() {

src_compile() {
emake

if use doc ; then
cd ode/doc
doxygen Doxyfile || die
fi
}

src_install() {
DOCS="CHANGELOG.txt README.txt" \
default
prune_libtool_files
default

find "${ED}" -name '*.la' -delete || die

if use doc ; then
dohtml docs/*
docinto html
dodoc docs/*
fi
if use examples; then
cd ode/demo

if use examples ; then
cd ode/demo || die

exeinto /usr/share/doc/${PF}/examples

local f
for f in *.c* ; do
doexe .libs/${f%.*}
done
cd ../..

cd ../.. || die

doexe drawstuff/dstest/dstest
insinto /usr/share/doc/${PF}/examples
doins ode/demo/*.{c,cpp,h} \

docinto examples
dodoc ode/demo/*.{c,cpp,h} \
drawstuff/textures/*.ppm \
drawstuff/dstest/dstest.cpp \
drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
Expand Down
45 changes: 29 additions & 16 deletions dev-games/ode/ode-0.12.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit ltprune
EAPI=7

DESCRIPTION="Open Dynamics Engine SDK"
HOMEPAGE="http://ode.org/"
Expand All @@ -13,13 +12,19 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="debug doc double-precision examples gyroscopic static-libs"

RDEPEND="examples? (
RDEPEND="
examples? (
virtual/opengl
)"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
)
"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

DOCS=( CHANGELOG.txt README.txt )

src_prepare() {
default

sed -i \
-e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
drawstuff/src/Makefile.in \
Expand All @@ -41,30 +46,38 @@ src_configure() {

src_compile() {
emake

if use doc ; then
cd ode/doc
cd ode/doc || die
doxygen Doxyfile || die
fi
}

src_install() {
DOCS="CHANGELOG.txt README.txt" \
default
prune_libtool_files
default

find "${ED}" -name '*.la' -delete || die

if use doc ; then
dohtml docs/*
docinto html
dodoc docs/*
fi
if use examples; then
cd ode/demo

if use examples ; then
cd ode/demo || die

exeinto /usr/share/doc/${PF}/examples

local f
for f in *.c* ; do
doexe .libs/${f%.*}
done
cd ../..

cd ../.. || die

doexe drawstuff/dstest/dstest
insinto /usr/share/doc/${PF}/examples
doins ode/demo/*.{c,cpp,h} \
docinto examples
dodoc ode/demo/*.{c,cpp,h} \
drawstuff/textures/*.ppm \
drawstuff/dstest/dstest.cpp \
drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
Expand Down
53 changes: 35 additions & 18 deletions dev-games/ode/ode-0.14-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit autotools epatch ltprune
EAPI=7

inherit autotools

DESCRIPTION="Open Dynamics Engine SDK"
HOMEPAGE="http://ode.org/"
Expand All @@ -13,16 +14,25 @@ SLOT="0/6"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="debug doc double-precision examples gyroscopic static-libs"

RDEPEND="examples? (
virtual/glu
virtual/opengl )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
RDEPEND="
examples? (
virtual/glu
virtual/opengl
)
"
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

MY_EXAMPLES_DIR=/usr/share/doc/${PF}/examples

DOCS=( CHANGELOG.txt README.md )

PATCHES=(
"${FILESDIR}"/${PN}-0.14-gcc7.patch
)

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.14-gcc7.patch
default

sed -i \
-e "s:\$.*/drawstuff/textures:${MY_EXAMPLES_DIR}:" \
Expand All @@ -47,28 +57,35 @@ src_configure() {
src_compile() {
emake
if use doc ; then
cd ode/doc
cd ode/doc || die
doxygen Doxyfile || die
fi
}

src_install() {
DOCS="CHANGELOG.txt README.md" \
default
prune_libtool_files
default

find "${ED}" -name '*.la' -delete || die

if use doc ; then
dohtml docs/*
docinto html
dodoc docs/*
fi
if use examples; then
docompress -x "${MY_EXAMPLES_DIR}"
insinto "${MY_EXAMPLES_DIR}"
exeinto "${MY_EXAMPLES_DIR}"

if use examples ; then
docompress -x ${MY_EXAMPLES_DIR}

insinto ${MY_EXAMPLES_DIR}
exeinto ${MY_EXAMPLES_DIR}

doexe drawstuff/dstest/dstest
doins ode/demo/*.{c,cpp,h} \
drawstuff/textures/*.ppm \
drawstuff/dstest/dstest.cpp \
drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
cd ode/demo

cd ode/demo || die

local f
for f in *.c* ; do
doexe .libs/${f%.*}
Expand Down

0 comments on commit d7d89de

Please sign in to comment.