Skip to content

Commit

Permalink
kde-frameworks/kpackage: 5.77.0 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Dec 12, 2020
1 parent 7ade7cb commit d84151c
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-frameworks/kpackage/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kpackage-5.74.0.tar.xz 140364 BLAKE2B a1e61eb9dc8d70edad144fd8c09ef4a6d86d3bb58835d21e2f95ab4ad92fff593f42699342253ed779dc652719d6ed8bd38e43e84d2d4dbf13f53a6f3946679f SHA512 93790ed0cf527c93b2ba434ce0d4e753dcd31ab027c86e69d65a6f8075771b7d4b9ca9628a5164d1ff5aa4a69f84f11093df8f8d63f284127e2943aa8e443e72
DIST kpackage-5.76.0.tar.xz 140352 BLAKE2B 0784c0694d262cacf505d8e37a051ff2a7b6d5335e38ebfb97c204bb65d2471f93d08a0c64d6a59e4e9f4c40ce7551c20387097ba7ef8f03523f7ddce6343c45 SHA512 edee46213f94dbe63a069b04624b7f634b2203f7feee5b6749a88a6af37000b94344acabf62d0b99fc481b510a98a2abc8e7e4861b0d46fc630e7a38b81c6d7c
DIST kpackage-5.77.0.tar.xz 140368 BLAKE2B be642431191b17e29cf3e9f2ae8df562e8caa9f39002cb6015cc40f753c757e39d742803f19ef80cf8b31d5b1480434a270fb91da0b9a95323a31317b39f51c6 SHA512 752a5927f0df3985808b122d5bd774fe658bc6eed718a0921e46ff9577b6809d302db6f172af01f82b1e5001f3e02d851e30db12246ac433e0d94d7f11ea5583
39 changes: 39 additions & 0 deletions kde-frameworks/kpackage/kpackage-5.77.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PVCUT=$(ver_cut 1-2)
QTMIN=5.15.1
inherit ecm kde.org

DESCRIPTION="Framework to install and load packages of non binary content"

LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="man"

BDEPEND="
man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
"
DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
=kde-frameworks/karchive-${PVCUT}*:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/ki18n-${PVCUT}*:5
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package man KF5DocTools)
)

ecm_src_configure
}

src_test() {
#bug 650214
local myctestargs=( -E "(plasma-plasmoidpackagetest)" )
ecm_src_test
}

0 comments on commit d84151c

Please sign in to comment.