Skip to content

Commit

Permalink
app-laptop/mbpfan: update the live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
gktrk committed Apr 2, 2017
1 parent 9672119 commit d85cb12
Showing 1 changed file with 24 additions and 11 deletions.
35 changes: 24 additions & 11 deletions app-laptop/mbpfan/mbpfan-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,32 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit git-r3 linux-info systemd toolchain-funcs
inherit linux-info systemd toolchain-funcs

DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
HOMEPAGE="https://github.com/dgraziotin/mbpfan"
EGIT_REPO_URI="git://github.com/dgraziotin/${PN}.git"
LICENSE="GPL-3+"
SLOT="0"
RESTRICT="test" # will fail if the hardware is unavailable, not useful

if [[ "${PV}" = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/dgraziotin/${PN}.git"
KEYWORDS=""
else
SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"

src_prepare() {
sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
default
src_compile() {
emake CC="$(tc-getCC)"
}

src_install() {
emake DESTDIR="${D%/}" install

rm -r "${D}"usr/share/doc/${PN} || die
rm -r "${D}"lib/systemd/system || die
# There's a double linking problem in install
emake DESTDIR="${ED}" CC="$(tc-getCC)" install

newinitd ${PN}.init.gentoo ${PN}
# Remove the empty systemd unit directory
# It doesn't actually install the unit file
rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
# Actually install the sytstemd unit file
systemd_dounit ${PN}.service
# Install openrc init file
newinitd ${PN}.init.gentoo ${PN}

# make install doesn't install the docs in the right place
rm -rf "${ED%/}/usr/share/doc/${PN}" || die

einstalldocs
}

0 comments on commit d85cb12

Please sign in to comment.