Skip to content

Commit

Permalink
Merge remote-tracking branch 'github/pr/917'
Browse files Browse the repository at this point in the history
  • Loading branch information
akhuettel committed Feb 25, 2016
2 parents 9003f78 + cffaca9 commit d94a5a1
Show file tree
Hide file tree
Showing 5 changed files with 42 additions and 48 deletions.
22 changes: 22 additions & 0 deletions app-text/libabw/files/libabw-0.1.1-boost-1.59.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
From: David Tardon <[email protected]>
Date: Sun, 30 Aug 2015 06:05:31 +0000 (+0200)
Subject: fix build with boost 1.59
X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=libabw.git;a=commitdiff_plain;h=ee2d0729315888d1847587ad556470d2fdc883a7;hp=7ea0b5530cf321cd80231b84421e4c107d1cc479

fix build with boost 1.59

Change-Id: I5645629526a8d9d896e4faeb2c7b9ea88540fd23
---

diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 5766f39..d12d8e2 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -26,6 +26,7 @@ generated_files = \
$(top_builddir)/src/lib/tokens.h \
$(top_builddir)/src/lib/tokenhash.h

+libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_CPPFLAGS = -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_LIBADD = $(REVENGE_LIBS) $(LIBXML_LIBS) $(ZLIB_LIBS) @LIBABW_WIN32_RESOURCE@
libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_DEPENDENCIES = @LIBABW_WIN32_RESOURCE@
libabw_@ABW_MAJOR_VERSION@_@ABW_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic $(no_undefined)
1 change: 1 addition & 0 deletions app-text/libabw/libabw-0.1.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -31,6 +31,7 @@ PATCHES=(
# from git master
"${FILESDIR}/${PN}-0.1.1-dereference-before-null-check.patch"
"${FILESDIR}/${PN}-0.1.1-do-not-let-AbiDocument_parse-throw.patch"
"${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
)

src_configure() {
Expand Down
42 changes: 12 additions & 30 deletions dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
Original file line number Diff line number Diff line change
@@ -1,21 +1,21 @@
--- a/configure.ac 2016-02-06 17:08:05.505990463 +0100
+++ b/configure.ac 2016-02-06 17:08:42.316530268 +0100
@@ -15,18 +15,13 @@
@@ -15,18 +15,22 @@
AC_INIT([libixion], [ixion_version])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign dist-bzip2 dist-xz])
-AM_PATH_PYTHON(2.7.0)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])

-AC_ARG_WITH(hash-container-compat,
-[
- --with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
-],
-,with_hash_container_compat=no)
-
-AC_ARG_WITH(mdds-include-path,
- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
-,)
AC_ARG_WITH(hash-container-compat,
[
--with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
],
,with_hash_container_compat=no)
AC_ARG_WITH(mdds-include-path,
AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
,)
+AC_ARG_ENABLE([python],
+ [AS_HELP_STRING([--disable-python], [Disable python bindings])],
+ [enable_python="$enableval"],
Expand All @@ -24,25 +24,7 @@

IXION_API_VERSION=ixion_api_version
IXION_MAJOR_VERSION=ixion_major_version
@@ -66,23 +61,19 @@
AC_FUNC_STRTOD
AC_CHECK_FUNCS([gettimeofday])

-CPPFLAGS="$CPPFLAGS -D_REENTRANT -DMDDS_HASH_CONTAINER_BOOST"
+CPPFLAGS="$CPPFLAGS -D_REENTRANT"

-AC_MSG_CHECKING([whether to turn on hash container compatibility])
-if test "z$with_hash_container_compat" = "zno"; then
- AC_MSG_RESULT([no])
- BOOST_REQUIRE([1.36])
- BOOST_UNORDERED
-else
- AC_MSG_RESULT([yes])
- DEFINES="$DEFINES -D_IXION_HASH_CONTAINER_COMPAT"
-fi
+BOOST_REQUIRE([1.36])

# Check for mdds.
@@ -70,7 +74,11 @@
PKG_CHECK_MODULES([MDDS],[mdds >= 0.12.0])

# Check for python.
Expand All @@ -55,7 +37,7 @@

CPPFLAGS="$CPPFLAGS -g -Os -fvisibility=hidden"

@@ -101,3 +92,10 @@
@@ -101,3 +109,10 @@
src/libixion/constants.inl
src/python/Makefile])
AC_OUTPUT
Expand Down
13 changes: 0 additions & 13 deletions dev-libs/libixion/files/libixion-0.9.1-python-symbol.patch

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"

Expand All @@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/ixion/ixion"
[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"

LICENSE="MIT"
SLOT="0/0.10"
SLOT="0/0.10" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="python static-libs"
Expand All @@ -37,9 +37,11 @@ pkg_setup() {
}

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.1-typo.patch" \
"${FILESDIR}/${PN}-0.9.1-python-optional.patch" \
"${FILESDIR}/${PN}-0.9.1-python-symbol.patch"
eapply_user

eapply "${FILESDIR}/${PN}-0.9.1-typo.patch" \
"${FILESDIR}/${PN}-0.9.1-python-optional.patch"

eautoreconf
}

Expand Down

0 comments on commit d94a5a1

Please sign in to comment.