Skip to content

Commit

Permalink
app-admin/puppet: 6.12.0 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Jan 16, 2020
1 parent 83d109e commit d9adb6d
Show file tree
Hide file tree
Showing 2 changed files with 140 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/puppet/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST puppet-4.10.12.tar.gz 3022218 BLAKE2B 03757857868b1544078ae5e40d6e438631c78
DIST puppet-5.5.17.tar.gz 3090402 BLAKE2B 7722ec4196ee766c29eddd7dc73539a4a5a0e4cc781a84af25210488328b5ae01178ca64e8eef14152cbeca06dc8fe145b5e39ce6a120d7689fc32cbbbe16f9f SHA512 95c6cd836a9f732ccfe2d8b83096e79c32428c43390c0826663f896ca1388e1fe3b55d93a5a7548831e95de85247db717866c36786d591e207341c734d70168b
DIST puppet-6.10.1.tar.gz 2809383 BLAKE2B 1589dcfa7d73b81ab7fbc3fca4b2fe956f5d240d11583c484262d5243e4713bb4aa9cd5c655e9566468050ab2e5c0ec0cc720e3ff9088add0744e02147b4e3bb SHA512 211c9837eb4a77a54bf09811a1a84709eef06f17e0c5c9c598d01bce2e183e69974709ad4dfb8f5fecd7433c1ff52757aa699c623155d1a0742f2e07eaf2ec56
DIST puppet-6.11.1.tar.gz 2816525 BLAKE2B c4b188d5bf76b70a2748b86df78f1ca6ab99951cbc3a16377d3f2d38e165bc78ef8e5648cb09264a25ae81ac4d379b9323b1f2bbdea6679292c2cf38cabee662 SHA512 f44196206331448651e0ff0e865b09c6ccbb19115edeba4c58c8a29aa35e7d76676d5a3cb35c51cd511a44115c9c9434f1f90d5cbb0a5551a4004741d305c879
DIST puppet-6.12.0.tar.gz 2825392 BLAKE2B fdb7007ca337654f5ee89cd6f3beae300c3eb952570eaf1aa9baad407b84b418916e42aed63855bbb250f1d367be12f98261df54253f6438d33950134ef01cce SHA512 bcb77699f4a4a058ea0fa47ee2b449f19053e3ae859e3e30c65a57ad65fc052a4f05d7a932b9cc4b9974b36dc343ac482258ad8d5a44a151362df474b82c11fe
139 changes: 139 additions & 0 deletions app-admin/puppet/puppet-6.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,139 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

USE_RUBY="ruby23 ruby24 ruby25"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC="doc:all"

RUBY_FAKEGEM_EXTRAINSTALL="locales"

inherit eutils user ruby-fakegem eapi7-ver

DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"

LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
RESTRICT="test"

ruby_add_rdepend "
dev-ruby/hiera
dev-ruby/json:=
dev-ruby/semantic_puppet
>=dev-ruby/facter-3.0.0
dev-ruby/concurrent-ruby
augeas? ( dev-ruby/ruby-augeas )
diff? ( dev-ruby/diff-lcs )
doc? ( dev-ruby/rdoc )
ldap? ( dev-ruby/ruby-ldap )
shadow? ( dev-ruby/ruby-shadow )
sqlite? ( dev-ruby/sqlite3 )
virtual/ruby-ssl
dev-ruby/hocon"

ruby_add_bdepend "
doc? ( dev-ruby/yard )
test? (
dev-ruby/mocha
dev-ruby/rack
dev-ruby/rspec-its
)"
# this should go in the above lists, but isn't because of test deps not being keyworded
# dev-ruby/rspec-collection_matchers

RDEPEND+=" ${RDEPEND}
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
sys-libs/libselinux[ruby]
sec-policy/selinux-puppet
)
vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
>=app-portage/eix-0.18.0"
PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"

pkg_setup() {
enewgroup puppet
enewuser puppet -1 -1 /var/lib/puppet puppet
}

all_ruby_prepare() {
# Avoid spec that require unpackaged json-schema.
rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die

# can't be run within portage.
epatch "${FILESDIR}/puppet-fix-tests-6.10.1.patch"

# fix systemd path
epatch "${FILESDIR}/puppet-systemd.patch"

# Avoid specs that can only run in the puppet.git repository. This
# should be narrowed down to the specific specs.
rm spec/integration/parser/compiler_spec.rb || die

# Avoid failing spec that need further investigation.
rm spec/unit/module_tool/metadata_spec.rb || die
}

each_ruby_install() {
each_fakegem_install
# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
}

all_ruby_install() {
all_fakegem_install

# systemd stuffs
insinto /usr/lib/systemd/system
doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"

# tmpfiles stuff
insinto /usr/lib/tmpfiles.d
newins "${FILESDIR}/tmpfiles.d" "puppet.conf"

# openrc init stuff
newinitd "${FILESDIR}"/puppet.init-4.x puppet

keepdir /etc/puppetlabs/puppet/ssl

keepdir /var/lib/puppet/facts
keepdir /var/lib/puppet/files
fowners -R puppet:puppet /var/lib/puppet

fperms 0750 /var/lib/puppet

fperms 0750 /etc/puppetlabs
fperms 0750 /etc/puppetlabs/puppet
fperms 0750 /etc/puppetlabs/puppet/ssl
fowners -R :puppet /etc/puppetlabs
fowners -R :puppet /var/lib/puppet

if use ldap ; then
insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi

# ext and examples files
for f in $(find ext examples -type f) ; do
docinto "$(dirname ${f})"; dodoc "${f}"
done
}

pkg_postinst() {
elog
elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
elog "cause puppet to hang while installing packages."
elog
elog "Portage Puppet module with Gentoo-specific resources:"
elog "http://forge.puppetlabs.com/gentoo/portage"
elog
elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
elog "not already done so."
elog
}

0 comments on commit d9adb6d

Please sign in to comment.