Skip to content

Commit

Permalink
app-doc/tldp-howto: update EAPI 5 -> 7
Browse files Browse the repository at this point in the history
* Port to EAPI 7
* Add missing || dies

Signed-off-by: Sam James <[email protected]>
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
thesamesam authored and SoapGentoo committed May 13, 2021
1 parent 2c571d7 commit d9b5258
Showing 1 changed file with 26 additions and 16 deletions.
42 changes: 26 additions & 16 deletions app-doc/tldp-howto/tldp-howto-20120707.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

DESCRIPTION="The Linux Documentation Project HOWTOs"
HOMEPAGE="http://www.tldp.org"
Expand All @@ -19,43 +19,53 @@ KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="+html htmlsingle pdf text"
REQUIRED_USE="|| ( html htmlsingle pdf text )"

DEPEND=""
RDEPEND="${DEPEND}"

RESTRICT="binchecks strip"

src_unpack() {
mkdir -p "${S}" || die
cd "${S}"
cd "${S}" || die

if use html; then
unpack Linux-html-HOWTOs-${PV}.tar.bz2

# for some reason this bundles the pdfs - older versions didn't
[[ -d ${S}/HOWTO/pdf ]] && rm -r "${S}"/HOWTO/pdf
if [[ -d "${S}"/HOWTO/pdf ]] ; then
rm -r "${S}"/HOWTO/pdf || die
fi

# stray bin file, doubt anyone will ever need it
rm -f "${S}"/HOWTO/RedHat-CD-HOWTO/rhcd-scripts/rvc
mv "${S}"/HOWTO "${S}"/html
rm -f "${S}"/HOWTO/RedHat-CD-HOWTO/rhcd-scripts/rvc || die
mv "${S}"/HOWTO "${S}"/html || die
fi

if use htmlsingle; then
mkdir "${S}"/htmlsingle || die
pushd "${S}"/htmlsingle > /dev/null
pushd "${S}"/htmlsingle > /dev/null || die

unpack Linux-html-single-HOWTOs-${PV}.tar.bz2
popd > /dev/null

popd > /dev/null || die
fi

if use pdf; then
mkdir "${S}"/pdf || die
pushd "${S}"/pdf > /dev/null
pushd "${S}"/pdf > /dev/null || die

unpack Linux-pdf-HOWTOs-${PV}.tar.bz2
popd > /dev/null

popd > /dev/null || die
fi

if use text; then
mkdir "${S}"/text || die
pushd "${S}"/text > /dev/null
pushd "${S}"/text > /dev/null || die

unpack Linux-HOWTOs-${PV}.tar.bz2
popd > /dev/null

popd > /dev/null || die
fi
}

src_install() {
insinto /usr/share/doc/${PF}
doins -r "${S}"/*
dodoc -r "${S}"/*
}

0 comments on commit d9b5258

Please sign in to comment.