Skip to content

Commit

Permalink
xfce-extra/tumbler: Bump to 0.3.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 15, 2020
1 parent 96cd1c2 commit da0823b
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions xfce-extra/tumbler/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tumbler-0.2.9.tar.bz2 557794 BLAKE2B 564b0d91489ee617799749db13085301f8b7195736ee01cd44d1e4bee7130a34235deaaac973f9be902b63eab46c69a5a277872204f53067d15645556f00dd42 SHA512 df9cf9b2ba77e220f11c5ca3ec4601c973802b802e989dcd24d1b2c7c13e97c185071488c866f3ed5ed1cc6defde1a4879b5fc2c48bfc015456508e526d6bf0f
DIST tumbler-0.3.0.tar.bz2 559424 BLAKE2B e9f9674a5fb3d9acba6435e9a5d1eada27269c24c395211a71dc3c3d751aa20f82ee154b5ebb36c2aecf34710e975b9167277e25cf8b210e8d4014e429a0d944 SHA512 e216a9c8c659457c6e6dbb40d95cd9a34d64d204fea9523d0a66f1c331108f6e01fb83d668b99eed73ed26579ae3a717cd3215ddceaebfff888d942ecb18469b
DIST tumbler-0.3.1.tar.bz2 559835 BLAKE2B 69f0c1d904b908fcef5ef42388600b8371b37e885ca38bdcdacbc5fefabec2fd49a8aba737832621f8942e788f5c52eb5da0acdd66cbe18f452b706df0d9fd9f SHA512 42bfe9b10411f07e8c9aca40ba8d1829f677fdb65d1b2612a7345f7f467d5a02761fa758359ac3c2eb1e1622bb9f659787cdd21dc2b711424ff64025f08ea375
1 change: 1 addition & 0 deletions xfce-extra/tumbler/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<name>XFCE Team</name>
</maintainer>
<use>
<flag name="epub">Enable support for .epub thumbnailer using <pkg>app-text/libgepub</pkg></flag>
<flag name="odf">Enable support for .odf thumbnailers by using <pkg>gnome-extra/libgsf</pkg></flag>
</use>
</pkgmetadata>
69 changes: 69 additions & 0 deletions xfce-extra/tumbler/tumbler-0.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit xdg-utils

DESCRIPTION="A thumbnail service for Thunar"
HOMEPAGE="https://docs.xfce.org/xfce/thunar/start"
SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="curl epub ffmpeg gstreamer jpeg odf pdf raw"

DEPEND=">=dev-libs/glib-2.42:2
media-libs/freetype:2=
media-libs/libpng:0=
>=sys-apps/dbus-1.6
>=x11-libs/gdk-pixbuf-2.14:2
curl? ( >=net-misc/curl-7.25:= )
epub? ( app-text/libgepub )
ffmpeg? ( >=media-video/ffmpegthumbnailer-2.0.8:= )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
)
jpeg? ( virtual/jpeg:0= )
odf? ( >=gnome-extra/libgsf-1.14.20:= )
pdf? ( >=app-text/poppler-0.12.4[cairo] )
raw? ( >=media-libs/libopenraw-0.0.8:=[gtk] )"
RDEPEND="${DEPEND}
gstreamer? ( media-plugins/gst-plugins-meta:1.0 )"
BDEPEND="
dev-util/gdbus-codegen
dev-util/gtk-doc-am
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"

src_configure() {
local myconf=(
$(use_enable curl cover-thumbnailer)
$(use_enable epub gepub-thumbnailer)
$(use_enable jpeg jpeg-thumbnailer)
$(use_enable ffmpeg ffmpeg-thumbnailer)
$(use_enable gstreamer gstreamer-thumbnailer)
$(use_enable odf odf-thumbnailer)
$(use_enable pdf poppler-thumbnailer)
$(use_enable raw raw-thumbnailer)
)

econf "${myconf[@]}"
}

src_install() {
default

find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit da0823b

Please sign in to comment.