Skip to content

Commit

Permalink
dev-vcs/guilt: Fix help system (#642584 by Terra)
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/642584
Signed-off-by: Pacho Ramos <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
pacho2 committed Oct 20, 2018
1 parent a1af4b8 commit da22c73
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
41 changes: 41 additions & 0 deletions dev-vcs/guilt/files/guilt-0.36-fix-help.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
From 53db96dd0c37b2fd299a26a00ba9b6f53cf6224e Mon Sep 17 00:00:00 2001
Date: Thu, 28 Dec 2017 20:01:08 -0500
Subject: [PATCH] Fix broken guilt help system

https://bugs.gentoo.org/642584
---
guilt | 4 ++--
guilt-help | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/guilt b/guilt
index 35177b9..498dfb6 100755
--- a/guilt
+++ b/guilt
@@ -73,8 +73,8 @@ GUILT_PATH="$(dirname "$0")"

guilt_commands()
{
- find "$GUILT_PATH/../lib/guilt" -maxdepth 1 -name "guilt-*" -type f -perm +111 2> /dev/null | sed -e "s/.*\\/$GUILT-//"
- find "$GUILT_PATH" -maxdepth 1 -name "guilt-*" -type f -perm +111 | sed -e "s/.*\\/$GUILT-//"
+ find "$GUILT_PATH/../lib/guilt" -maxdepth 1 -name "guilt-*" -type f -executable 2> /dev/null | sed -e "s/.*\\/$GUILT-//"
+ find "$GUILT_PATH" -maxdepth 1 -name "guilt-*" -type f -executable | sed -e "s/.*\\/$GUILT-//"
}

# by default, we shouldn't fail
diff --git a/guilt-help b/guilt-help
index 93442a3..b29e059 100755
--- a/guilt-help
+++ b/guilt-help
@@ -34,7 +34,7 @@ case $# in
;;
esac

-MANDIR=`dirname $0`/../man
+MANDIR=`dirname $0`/../share/man
MANDIR=`(cd "$MANDIR"; pwd)`
exec man -M "$MANDIR" "$page"

--
2.13.5

53 changes: 53 additions & 0 deletions dev-vcs/guilt/guilt-0.36-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="A series of bash scripts which add a quilt-like interface to git"
HOMEPAGE="http://repo.or.cz/w/guilt.git"
SRC_URI="${HOMEPAGE}/snapshot/22d785dd24329170f66e7696da38b3e90e033d61.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""

# Since we need to build the man pages anyway, I don't think it makes
# much sense to hide the HTML docs behind USE=doc.
RDEPEND="dev-vcs/git"
DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto
dev-lang/perl
"

RESTRICT="test"

S="${WORKDIR}/${PN}-22d785d"

src_prepare() {
default

eapply "${FILESDIR}"/${P}-fix-help.patch

# The doc makefile tries to shell out to `git` for the version.
sed -i Documentation/Makefile \
-e "s/VERSION=.*/VERSION=${PV}/" \
|| die 'failed to set VERSION in Documentation/Makefile'
}

src_compile() {
emake -C Documentation all
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr install

dodoc Documentation/{Contributing,Features,HOWTO,Requirements}
emake -C Documentation \
DESTDIR="${D}" \
PREFIX=/usr \
mandir=/usr/share/man \
htmldir="/usr/share/doc/${PF}/html" \
install install-html
}

0 comments on commit da22c73

Please sign in to comment.