Skip to content

Commit

Permalink
app-arch/lz4: Version bump to r131
Browse files Browse the repository at this point in the history
Bump to upstream revision 131. Fix the build procedure following
Makefile changes. Bump subslot to current revision since upstream
changed ABI without bumping SONAME.

Fixes: https://bugs.gentoo.org/show_bug.cgi?id=522860
  • Loading branch information
mgorny committed Nov 3, 2015
1 parent d56e5f5 commit dadf361
Show file tree
Hide file tree
Showing 3 changed files with 72 additions and 7 deletions.
1 change: 1 addition & 0 deletions app-arch/lz4/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lz4-0_p106.tar.xz 129352 SHA256 a9a09c4ebb962995d10e7e4f7d9224aaa93f308899de18a414948a58e87b6f22 SHA512 8b2bafbf78be7c42831e264d7acdca12712c88369cecdb3aa4621c84bb6b450c372f5153f7c3939a5f70d5810c62b98993697397319d286a1bb51b1e4a6ecde6 WHIRLPOOL fc5bb47b73606b125d8e155365d1fe101083e68e684ffd6014440e0f1416f1f6ecc64b797083e6939bd3e8cd42018e46a1864ae4542160c96933a47df9421a42
DIST lz4-r120.tar.gz 161950 SHA256 fa02b1bcc26529c27cff0883d830914bdd1ba41a87035313e1050302f17e4b07 SHA512 8b27c57737ba4c2c8e4f00f7ce13f6edc91f74885bad66dd521dfe85d427e0fd78a300896d599bb8642a34fba78446daf207d1b2fd8e91543d4c093e53694e86 WHIRLPOOL 6a0cd7f8caf9799130b13b3f282197b5ef20fb987f0f5f6911f71a0f5d5d37c542976be5f13bdd2e21a8edd0a6cc8408fcc0f69f6354a0fbc7df75b22fb9de91
DIST lz4-r131.tar.gz 133784 SHA256 9d4d00614d6b9dec3114b33d1224b6262b99ace24434c53487a0c8fd0b18cfed SHA512 60bd95d529691ffee2c43f0d8a62484c3cff74c0154094f073192606806ac8182dced61e0534ffa7e0ccf5f18e9a8cfd2738883a83814c0711a6d7f1d1b252e5 WHIRLPOOL d605dbada1d4eb84eb6f3f45417eaa35433b1e3e875af560bb5fa06f0465f1652fab74c094d0d743e0034abc0067c83114827e21baea69d5c3d6d95062d0f660
54 changes: 54 additions & 0 deletions app-arch/lz4/lz4-0_p131.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit multilib multilib-minimal toolchain-funcs

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Cyan4973/lz4.git"
EGIT_BRANCH=dev
else
MY_PV="r${PV##0_p}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://github.com/Cyan4973/lz4/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi

DESCRIPTION="Extremely Fast Compression algorithm"
HOMEPAGE="https://github.com/Cyan4973/lz4"

LICENSE="BSD-2 GPL-2"
# Upstream has trouble keeping ABI stable, so please test new versions
# with abi-compliance-checker and update the subslot every time ABI
# changes. This is the least we can do to keep things sane.
SLOT="0/r131"
IUSE="test valgrind"

DEPEND="test? ( valgrind? ( dev-util/valgrind ) )"

src_prepare() {
if ! use valgrind; then
sed -i -e '/^test:/s|test-mem||g' programs/Makefile || die
fi
multilib_copy_sources
}

multilib_src_compile() {
tc-export CC AR
# we must not use the 'all' target since it builds test programs
# & extra -m32 executables
emake -C lib liblz4 liblz4.pc
emake -C programs lz4 lz4c
# work around lack of proper target dependencies
touch lib/liblz4
}

multilib_src_install() {
emake install DESTDIR="${D}" \
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}"/usr/$(get_libdir)
}
24 changes: 17 additions & 7 deletions app-arch/lz4/lz4-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -11,30 +11,40 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/Cyan4973/lz4.git"
EGIT_BRANCH=dev
else
SRC_URI="https://dev.gentoo.org/~ryao/dist/${P}.tar.xz"
MY_PV="r${PV##0_p}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://github.com/Cyan4973/lz4/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi

DESCRIPTION="Extremely Fast Compression algorithm"
HOMEPAGE="https://github.com/Cyan4973/lz4"

LICENSE="BSD-2 GPL-2"
SLOT="0"
IUSE="test"
# Upstream has trouble keeping ABI stable, so please test new versions
# with abi-compliance-checker and update the subslot every time ABI
# changes. This is the least we can do to keep things sane.
SLOT="0/r131"
IUSE="test valgrind"

RDEPEND=""
DEPEND="test? ( dev-util/valgrind )"
DEPEND="test? ( valgrind? ( dev-util/valgrind ) )"

src_prepare() {
if ! use valgrind; then
sed -i -e '/^test:/s|test-mem||g' programs/Makefile || die
fi
multilib_copy_sources
}

multilib_src_compile() {
tc-export CC AR
# we must not use the 'all' target since it builds test programs
# & extra -m32 executables
emake
emake -C programs
emake -C lib liblz4 liblz4.pc
emake -C programs lz4 lz4c
# work around lack of proper target dependencies
touch lib/liblz4
}

multilib_src_install() {
Expand Down

0 comments on commit dadf361

Please sign in to comment.