Skip to content

Commit

Permalink
dev-libs/check: new revision with missing virtual/pkgconfig DEPEND.
Browse files Browse the repository at this point in the history
Gentoo-Bug: 504658

Package-Manager: portage-2.2.28
  • Loading branch information
orlitzky committed Aug 12, 2016
1 parent 0f59278 commit db7625c
Showing 1 changed file with 11 additions and 11 deletions.
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"

inherit autotools autotools-multilib eutils
inherit autotools autotools-multilib

DESCRIPTION="A unit test framework for C"
HOMEPAGE="https://sourceforge.net/projects/check/"
Expand All @@ -17,8 +17,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs subunit"

DEPEND="subunit? ( >=dev-python/subunit-0.0.10-r1[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
RDEPEND="subunit? ( >=dev-python/subunit-0.0.10-r1[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
# See multilib_src_test(), disable sleep()-based tests because they
Expand All @@ -27,14 +28,12 @@ pkg_setup() {
}

src_prepare() {
sed -i -e '/^docdir =/d' {.,doc}/Makefile.am || die
sed -i -e '/^docdir =/d' {.,doc}/Makefile.am \
|| die 'failed to unset docdir in Makefile.am'

# fix out-of-sourcedir build having inconsistent check.h files, for
# example breaks USE=subunit.
rm src/check.h || die

# Fix automake warnings being treated as errors, bug #420373
sed -i -e s/-Werror// configure.ac || die
rm src/check.h || die 'failed to remove src/check.h'

eautoreconf
}
Expand All @@ -43,7 +42,7 @@ src_configure() {
local myeconfargs=(
--disable-dependency-tracking
$(use_enable subunit)
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--docdir="${EPREFIX}/usr/share/doc/${PF}"
)
autotools-multilib_src_configure
}
Expand All @@ -59,5 +58,6 @@ src_install() {
autotools-multilib_src_install
dodoc AUTHORS *ChangeLog* NEWS README THANKS TODO

rm -f "${ED}"/usr/share/doc/${PF}/COPYING* || die
rm -f "${ED}/usr/share/doc/${PF}"/COPYING* || \
die 'failed to remove COPYING files'
}

0 comments on commit db7625c

Please sign in to comment.