Skip to content

Commit

Permalink
sys-boot/unetbootin: Test LINGUAS rather than linguas_* USE flags.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
ulm committed Jan 7, 2018
1 parent ec8f7aa commit db8c331
Show file tree
Hide file tree
Showing 4 changed files with 12 additions and 28 deletions.
10 changes: 3 additions & 7 deletions sys-boot/unetbootin/unetbootin-625.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand All @@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"

for lingua in ${UNBI_LINGUAS}; do
IUSE="${IUSE} linguas_${lingua}"
done

S=${WORKDIR}/${P}/src/${PN}

DEPEND="dev-qt/qtgui:4"
Expand Down Expand Up @@ -52,7 +48,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
if ! use linguas_${lingua}; then
if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
Expand Down Expand Up @@ -82,7 +78,7 @@ src_install() {

local lingua
for lingua in ${UNBI_LINGUAS}; do
if use linguas_${lingua}; then
if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
Expand Down
10 changes: 3 additions & 7 deletions sys-boot/unetbootin/unetbootin-647.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"

for lingua in ${UNBI_LINGUAS}; do
IUSE="${IUSE} linguas_${lingua}"
done

S=${WORKDIR}/${P}/src/${PN}

DEPEND="dev-qt/qtgui:4"
Expand Down Expand Up @@ -51,7 +47,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
if ! use linguas_${lingua}; then
if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
Expand Down Expand Up @@ -81,7 +77,7 @@ src_install() {

local lingua
for lingua in ${UNBI_LINGUAS}; do
if use linguas_${lingua}; then
if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
Expand Down
10 changes: 3 additions & 7 deletions sys-boot/unetbootin/unetbootin-655.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"

for lingua in ${UNBI_LINGUAS}; do
IUSE="${IUSE} linguas_${lingua}"
done

S=${WORKDIR}/${P}/src/${PN}

DEPEND="dev-qt/qtgui:4"
Expand Down Expand Up @@ -50,7 +46,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
if ! use linguas_${lingua}; then
if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
Expand Down Expand Up @@ -80,7 +76,7 @@ src_install() {

local lingua
for lingua in ${UNBI_LINGUAS}; do
if use linguas_${lingua}; then
if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
Expand Down
10 changes: 3 additions & 7 deletions sys-boot/unetbootin/unetbootin-657.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"

for lingua in ${UNBI_LINGUAS}; do
IUSE="${IUSE} linguas_${lingua}"
done

S=${WORKDIR}/${P}/src/${PN}

DEPEND="dev-qt/qtgui:4"
Expand Down Expand Up @@ -50,7 +46,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
if ! use linguas_${lingua}; then
if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
Expand Down Expand Up @@ -80,7 +76,7 @@ src_install() {

local lingua
for lingua in ${UNBI_LINGUAS}; do
if use linguas_${lingua}; then
if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
Expand Down

0 comments on commit db8c331

Please sign in to comment.