Skip to content

Commit

Permalink
dev-java/bcmail: Set SLOT back to 1.50 and adjust dependencies accord…
Browse files Browse the repository at this point in the history
…ingly.

Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Oct 17, 2015
1 parent 344ac17 commit dbe2176
Showing 1 changed file with 67 additions and 0 deletions.
67 changes: 67 additions & 0 deletions dev-java/bcmail/bcmail-1.50-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

JAVA_PKG_IUSE="doc source test"

inherit java-pkg-2 java-pkg-simple

MY_P="${PN}-jdk15on-${PV/./}"

DESCRIPTION="Java cryptography APIs"
HOMEPAGE="http://www.bouncycastle.org/java.html"
SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="1.50"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"

CDEPEND="dev-java/bcprov:${SLOT}
dev-java/bcpkix:${SLOT}
dev-java/sun-jaf:0
dev-java/junit:0
dev-java/oracle-javamail:0"

DEPEND=">=virtual/jdk-1.6
app-arch/unzip
${CDEPEND}"

RDEPEND=">=virtual/jre-1.6
${CDEPEND}"

S="${WORKDIR}/${MY_P}"

JAVA_GENTOO_CLASSPATH="
junit
bcprov-${SLOT}
bcpkix-${SLOT}
sun-jaf
oracle-javamail
"

# Package can't be built with test as bcprov and bcpkix can't be built with test.
RESTRICT="test"

src_unpack() {
default
cd "${S}"
unpack ./src.zip
}

java_prepare() {
JAVA_RM_FILES=(
org/bouncycastle/mail/smime/test/*
org/bouncycastle/mail/smime/examples/CreateSignedMail.java
)
}

src_compile() {
java-pkg-simple_src_compile
}

src_install() {
java-pkg-simple_src_install
use source && java-pkg_dosrc org
}

0 comments on commit dbe2176

Please sign in to comment.