Skip to content

Commit

Permalink
dev-haskell/authenticate: bump up to 1.3.3.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
Sergei Trofimovich committed May 11, 2016
1 parent aaae196 commit dc72826
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/authenticate/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST authenticate-1.3.2.11.tar.gz 8728 SHA256 049388bf2ebf9017f3854462e1e2af57366959528e815017651e8da112577ff6 SHA512 8e1358bd6dd62f10b372fd5df6bd2b50f1c161ade466316efa9e036c17be97e7c561eab968a2e17d28cc12988db454618bf11b8c9bc5e9a20d864423756eccb5 WHIRLPOOL 409b9faa2b879b6a1b7fd58878dc29209c701f6aba4a83fb8465d8a2a5385246a2793b108f50dc0f4461d8d6f403030986962089880ea4f211e431b57204a1e2
DIST authenticate-1.3.3.1.tar.gz 8703 SHA256 652449f41b12a71f570fd84f53893f82e50b7d793a0724d349188ce19d623113 SHA512 e2caa227dfc4a4878ac7011d79d98c539320cb2fe5d9e260a9c71951486ba8af396fbcd0ccf3cb80205063881c7922f3d1a62d693ff8e1529b88e3cfc2e3c5c8 WHIRLPOOL 6722bedd20045c7911eead9c02851f9f07809950027929754d010a4429279e8d773b4327e7ba2690dd948dcdbb70ca087e56830e39fba1b018e47dd6af8d678c
46 changes: 46 additions & 0 deletions dev-haskell/authenticate/authenticate-1.3.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

# ebuild generated by hackport 0.4.7.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal

DESCRIPTION="Authentication methods for Haskell web applications"
HOMEPAGE="https://github.com/yesodweb/authenticate"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+network-uri"

RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
dev-haskell/attoparsec:=[profile?]
dev-haskell/blaze-builder:=[profile?]
>=dev-haskell/case-insensitive-0.2:=[profile?]
>=dev-haskell/conduit-0.5:=[profile?]
>=dev-haskell/http-conduit-1.5:=[profile?]
>=dev-haskell/http-types-0.6:=[profile?]
dev-haskell/monad-control:=[profile?]
dev-haskell/resourcet:=[profile?]
>=dev-haskell/tagstream-conduit-0.5.5:=[profile?]
dev-haskell/text:=[profile?]
>=dev-haskell/transformers-0.1:=[profile?]
dev-haskell/unordered-containers:=[profile?]
>=dev-haskell/xml-conduit-1.0:=[profile?]
>=dev-lang/ghc-7.4.1:=
network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
!network-uri? ( <dev-haskell/network-2.6:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag network-uri network-uri)
}

0 comments on commit dc72826

Please sign in to comment.