Skip to content

Commit

Permalink
dev-python/fabric: Add bach-completion support
Browse files Browse the repository at this point in the history
thanks OzTiram for the initial ebuild patch

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573702

Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Feb 9, 2016
1 parent aba3215 commit dcc610d
Show file tree
Hide file tree
Showing 2 changed files with 20 additions and 7 deletions.
1 change: 1 addition & 0 deletions dev-python/fabric/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST Fabric-1.10.0.tar.gz 208969 SHA256 edb2702b4655600f0a49a97e654c79f5b21490ce30f77d1313dd851f0b60335a SHA512 991341dfb3f71e938c2a2e30f5bc158be84cb1600ab64c4f7c5c49decd0a38bc57615f9e07edfbed70d9ca796592d7c1a4f7f3e25a40c4d31049015df928b2e3 WHIRLPOOL c07ba33bd6e7832fd5527ec14e206d74a6a2b983dbb49a43d972f31e15e22f9642df4809adff72f43f92fca5c1d758a4ac540ed87e22f46adc25094b2aa4ccb3
DIST Fabric-1.10.1.tar.gz 209750 SHA256 ab9c54e9496c89ae96ed4aa669e01c792376d75a7389ec90d4292282cc26f008 SHA512 a00f46ac28c61d20575af9f34e4e2bc54a79e836c29b395bbdf58538b6c75523a7ec6f3f40caf0f270d2ec8b0500806b14e80c4ed4d2077e39f4dbdd773d8637 WHIRLPOOL 88b5865ec80ff923292b0ba4a868a06fa5cc0f68b3a8ab2fbfb68f17422b9b60a365ea3b14b5f04929425bbcf9350acbc72dc1733200c18a80d954c3c1762ce9
DIST Fabric-1.10.2.tar.gz 212942 SHA256 666a3da92273532d3a49dd1ac53e3d721c5ec2f2512cd7dddb7ce19e29e9f038 SHA512 3102616a8fbc6237df74eb9b506e95628487d2bb112a56826d388a943b6e8af926f4f174a8d8810b27b63e58d2018667d927795c6a5e53833a1d3fc87324b0af WHIRLPOOL f08af6300432655786692a99385f4cd4d8605ac3bd952dd198706bd975c737431df7aaa6dc2d737719ca029305cb3e3359876ac32702f3ad539b65a5ad5501fb
DIST fabric-1.10.2-completion.bash 4266 SHA256 9346541b636f001d4efe1ee0bf0a7a083e85789c88ebd54910004b39ee3f68fa SHA512 2303e3b6a71ac8f6a61ce3bd464f3c950db8374b61a6375ccc6fbb2dc815a4a44509a034788862bd361ace7c0f401533cd5cee0fb6fca8d9ff7e0ffd143706a3 WHIRLPOOL 616cefd147905347c38ac7ea91ec465be12435ffe48c487083c9d0f1767bb12e5f82423c132b7cc82a89575869729ac1e530d82cf1831c97f0586be5262d8cab
Original file line number Diff line number Diff line change
@@ -1,18 +1,23 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1
inherit bash-completion-r1 distutils-r1

MY_PN="Fabric"
MY_P="${MY_PN}-${PV}"

COMP_HASH="83d303e9fb352deaf4885b6db0781b3d9115e9c6"

DESCRIPTION="A simple pythonic tool for remote execution and deployment"
HOMEPAGE="http://fabfile.org https://pypi.python.org/pypi/Fabric"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
SRC_URI="
mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
https://raw.githubusercontent.com/kbakulin/fabric-completion/${COMP_HASH}/fabric-completion.bash -> ${P}-completion.bash"

LICENSE="GPL-2"
SLOT="0"
Expand All @@ -23,10 +28,12 @@ RDEPEND="
>=dev-python/paramiko-1.10[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
>=dev-python/python-docs-2.7.6-r1:2.7
dev-python/alabaster[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
<dev-python/fudge-1.0[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}] )"

Expand All @@ -39,7 +46,8 @@ python_prepare_all() {
local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
sed -e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
sed \
-e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
-e "s| 'www'| #'www'|" \
-i sites/docs/conf.py || die
fi
Expand All @@ -54,10 +62,14 @@ python_compile_all() {

python_test() {
# 1 failure, reported https://github.com/fabric/fabric/issues/1360
sed \
-e 's:test_abort_message_only_printed_once:_&:g' \
-i tests/test_utils.py || die
esetup.py test
}

python_install_all() {
use doc && local HTML_DOCS=( sites/docs/html/. )
distutils-r1_python_install_all
newbashcomp "${DISTDIR}"/${P}-completion.bash ${PN}
}

0 comments on commit dcc610d

Please sign in to comment.