Skip to content

Commit

Permalink
dev-ros/gazebo_ros_control: fix build with urdfdom1 and add := dep on it
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
aballier committed Jul 26, 2016
1 parent 68f1a7d commit dd1ea63
Show file tree
Hide file tree
Showing 3 changed files with 19 additions and 3 deletions.
13 changes: 13 additions & 0 deletions dev-ros/gazebo_ros_control/files/urdfdom1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
Index: gazebo_ros_control/src/default_robot_hw_sim.cpp
===================================================================
--- gazebo_ros_control.orig/src/default_robot_hw_sim.cpp
+++ gazebo_ros_control/src/default_robot_hw_sim.cpp
@@ -381,7 +381,7 @@ void DefaultRobotHWSim::registerJointLim

if (urdf_model != NULL)
{
- const boost::shared_ptr<const urdf::Joint> urdf_joint = urdf_model->getJoint(joint_name);
+ const std::shared_ptr<const urdf::Joint> urdf_joint = urdf_model->getJoint(joint_name);
if (urdf_joint != NULL)
{
*joint_type = urdf_joint->type;
Original file line number Diff line number Diff line change
Expand Up @@ -22,8 +22,10 @@ RDEPEND="
dev-ros/hardware_interface
dev-ros/transmission_interface
dev-ros/pluginlib
dev-ros/joint_limits_interface
dev-ros/urdf
>=dev-ros/joint_limits_interface-0.11.0
>=dev-ros/urdf-1.12.3-r1
dev-libs/urdfdom:=
sci-electronics/gazebo
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/urdfdom1.patch" )
3 changes: 2 additions & 1 deletion dev-ros/gazebo_ros_control/gazebo_ros_control-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -25,5 +25,6 @@ RDEPEND="
dev-ros/joint_limits_interface
dev-ros/urdf
sci-electronics/gazebo
dev-libs/urdfdom:=
"
DEPEND="${RDEPEND}"

0 comments on commit dd1ea63

Please sign in to comment.