Skip to content

Commit

Permalink
dev-libs/libevent: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Jeroen Roovers committed Feb 2, 2017
1 parent cff4c00 commit dd8cf33
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libevent/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libevent-2.0.22-stable.tar.gz 854987 SHA256 71c2c49f0adadacfdbe6332a372c38cf9c8b7895bb73dabeaa53cdcc1d4e1fa3 SHA512 990637f12e890bfa7f86c194c8b112701436e92b60afb829194879efb85d558b986261e6508fe29bde73981feada874438e2d442cec8ea5730c889954f9bc907 WHIRLPOOL fe465e94a35dc489a86fad93fd4a82d5c314e3a66ebf1bcf8ba29014fe9bd2ebce4546b4a6a9fedee40d17010d73eb89b99596cec1dde3b7f9a4240cf6b6760d
DIST libevent-2.1.7_rc.tar.gz 696447 SHA256 548362d202e22fe24d4c3fad38287b4f6d683e6c21503341373b89785fa6f991 SHA512 72187614ddd5ce0ef0560d54e526ca9986dde90d4c1542637217ce62a596d800dedda88e4da383529ebf961c198929da59a2b570b1a19dba9d2506684af8cb3a WHIRLPOOL 5e7e71c22729b068890aacc1e157680489662078c509a1be7689f21707d1b4d40538f97debb6e93df0393fbaa309d3c81f900bebddd2a352782299ff441e2efc
DIST libevent-2.1.8.tar.gz 1026485 SHA256 965cc5a8bb46ce4199a47e9b2c9e1cae3b137e8356ffdad6d94d3b9069b71dc2 SHA512 a2fd3dd111e73634e4aeb1b29d06e420b15c024d7b47778883b5f8a4ff320b5057a8164c6d50b53bd196c79d572ce2639fe6265e03a93304b09c22b41e4c2a17 WHIRLPOOL ac90b6613619e0acf039fa331769449b29a3b7698a6d51b811c9288a550a3178e07b5a18a0982141ee90b7e1c34afdc80658355135963ef487cd243c472ee79a
67 changes: 67 additions & 0 deletions dev-libs/libevent/libevent-2.1.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils multilib-minimal

DESCRIPTION="A library to execute a function when a specific event occurs on a file descriptor"
HOMEPAGE="http://libevent.org/ https://github.com/libevent/libevent/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}-stable/${P}-stable.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
# libevent-2.1.so.6
SLOT="0/2.1-6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="debug libressl +ssl static-libs test +threads"

DEPEND="
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
)
"
RDEPEND="
${DEPEND}
!<=dev-libs/9libs-1.0
"

MULTILIB_WRAPPED_HEADERS=(
/usr/include/event2/event-config.h
)

S=${WORKDIR}/${P}-stable

src_prepare() {
default
eautoreconf
}

multilib_src_configure() {
# fix out-of-source builds
mkdir -p test || die

ECONF_SOURCE="${S}" \
econf \
--disable-samples \
$(use_enable debug debug-mode) \
$(use_enable debug malloc-replacement) \
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
$(use_enable test libevent-regress) \
$(use_enable threads thread-support)
}

src_test() {
# The test suite doesn't quite work (see bug #406801 for the latest
# installment in a riveting series of reports).
:
# emake -C test check | tee "${T}"/tests
}

DOCS=( ChangeLog{,-1.4,-2.0} )

multilib_src_install_all() {
einstalldocs
prune_libtool_files
}

0 comments on commit dd8cf33

Please sign in to comment.