Skip to content

Commit

Permalink
dev-db/mysql++: Version bump and fix for bug 608320
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Brian Evans committed Feb 5, 2017
1 parent d48f411 commit ddb9ced
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 2 deletions.
1 change: 1 addition & 0 deletions dev-db/mysql++/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST mysql++-2.3.2.tar.gz 1627115 SHA256 3544b964964bc8981118119e82e4883dc9d1de8
DIST mysql++-3.1.0.tar.gz 1944101 SHA256 256c39a583e7d60947916851754c626312428e9b1d8af3309e34d64ff8404e92 SHA512 bb57bbf03c80edabff701132877f407ecfa1b76958d7655415c59ec939e80fbe250951a16c3d5ea6988dd2c778b623605cb65bf810501f392be2f6b6ad07ad90 WHIRLPOOL 0b5274e0fbc1b2cb40ade9699ddc46d5837e66f3a506502f4dae5f5de4689ac2ccf3989a674db073a36075c541046b174e80bbac3d7df393bd61ef3bfc99fd32
DIST mysql++-3.2.1.tar.gz 2256735 SHA256 aee521873d4dbb816d15f22ee93b6aced789ce4e3ca59f7c114a79cb72f75d20 SHA512 936021dcf8568d3ee0c935e5c552acc6fd2b57849d1cc60e68b45b690d798d7bfbc1dedc04e21417d1b4c27017b471e4f6cb70de7f1904949b9222090a777de9 WHIRLPOOL 56579d4a1afb5985dc8487d211ea7e5aedfe7acfbcd6130b28b07364e66d6b0142831296a6c6ce2f4de78f45e94572c1ef289db41ee504b05d04f3623d48b2aa
DIST mysql++-3.2.2.tar.gz 3257359 SHA256 55667bee79a5981b1a04e57e3a4fd8b03bf330e4e3371b023c2bf5ba0f50ed17 SHA512 eb4250394027f1baafa660711d8221c9eb3a70ff2a37331c58807a97a67b84f792290b24830e851b2421f6ccf2867e9f3597af3af41530256c44521a4c4a55b1 WHIRLPOOL c344e77edf8fb5d09fc82c716441ecc53b00b97076d696c52072c79b0c754b7852959c4adac02240cf37ca9159a8f8174a086d43f7cd36388a2c26f2bec38a12
DIST mysql++-3.2.3.tar.gz 3241023 SHA256 c804c38fe229caab62a48a6d0a5cb279460da319562f41a16ad2f0a0f55b6941 SHA512 b6b0a9856ede9e5e08be0f5ed1689b1256f8cf31c3afbb9c9e7f68d0734380e25909ef31cd04be6b253c86b2f881df10f3793a2d3e32042375dbbab4b0700d0a WHIRLPOOL ea45deaa9a1c7c94e7790117b5f964d7af2e4b85be90dff444eeac4023295d2c076f1f6e8539182b502200c818b50f08543e0e9c7aa7cd9038b1084e1af64ce3
4 changes: 2 additions & 2 deletions dev-db/mysql++/files/mysql++-3.2.1-gold.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.in.orig 2013-09-27 09:51:48.646667442 -0400
+++ Makefile.in 2013-09-27 09:52:22.026603184 -0400
--- a/Makefile.in.orig 2013-09-27 09:51:48.646667442 -0400
+++ b/Makefile.in 2013-09-27 09:52:22.026603184 -0400
@@ -36,7 +36,7 @@
CXX = @CXX@
CXXFLAGS = @CXXFLAGS@
Expand Down
39 changes: 39 additions & 0 deletions dev-db/mysql++/mysql++-3.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils

DESCRIPTION="C++ API interface to the MySQL database"
HOMEPAGE="http://tangentsoft.net/mysql++/"
SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc"

RDEPEND="virtual/libmysqlclient:="
DEPEND="${RDEPEND}"
DOCS=( CREDITS.txt HACKERS.txt Wishlist doc/ssqls-pretty )

src_prepare() {
eapply "${FILESDIR}/${PN}-3.2.1-gold.patch"
eapply_user
# Current MySQL libraries are always with threads and slowly being removed
sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
rm "${S}/doc/"README-*-RPM.txt || die
}

src_configure() {
local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
econf ${myconf}
}

src_install() {
default
# install the docs and HTML pages
use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
}

0 comments on commit ddb9ced

Please sign in to comment.