Skip to content

Commit

Permalink
media-gfx/gphoto2: Version bump to 2.5.26
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/679332
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Nov 11, 2020
1 parent 3abd4ce commit de9268c
Show file tree
Hide file tree
Showing 3 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/gphoto2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gphoto2-2.5.20.tar.bz2 790065 BLAKE2B 6e10aa468696bc3eff51aaa3e886ad2373997f91597e42b33777ac56bf668f918c2fa0cb8b70eb8f7cb45507e67c9cfc3a46a7408449ad35cc3b743daf74859d SHA512 0350c38c264e5ba858ee14952fbf6ad271e7fef05e3f5f8eb3d45102099ae435fec63b09881efa99af60d4e086a9c2f69be92a7e49617643ab13146a5e4655f3
DIST gphoto2-2.5.26.tar.bz2 804521 BLAKE2B 20ddf39ad8668543864119cb1cf8dd5db4be5a773ccdd73efe434fe790ce001842512acf9a9f3ad08bad43460b42e4de257b2ca5561b5d7727f0703dba8f8098 SHA512 fbfc8d860db830be423271a0f569d51a296e9394884fe1a9e22eafd4ba0b7e4e68d86ba0391df81a64d4a4976b2644b2c39339532bd0e8e01f461b9a89cceb47
29 changes: 29 additions & 0 deletions media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
https://bugs.gentoo.org/679332

diff --git a/configure.ac b/configure.ac
index ed76a66..b0db85c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,7 +141,7 @@ AC_ARG_WITH([cdk-prefix],AS_HELP_STRING([--with-cdk-prefix=PREFIX],
if $try_cdk; then
CPPFLAGS_save="$CPPFLAGS"
CPPFLAGS="-I$cdk_prefix/include $CPPFLAGS"
- AC_CHECK_HEADER([cdk/cdk.h], [
+ AC_CHECK_HEADER([cdk.h], [
have_cdk=:
AC_PATH_PROG([CDK_CONFIG], [cdk5-config])
if test -n "${CDK_CONFIG}"; then
diff --git a/gphoto2/gphoto2-cmd-config.c b/gphoto2/gphoto2-cmd-config.c
index 360fd61..c801604 100644
--- a/gphoto2/gphoto2-cmd-config.c
+++ b/gphoto2/gphoto2-cmd-config.c
@@ -29,7 +29,7 @@

#include <gphoto2/gphoto2-widget.h>

-#include <cdk/cdk.h>
+#include <cdk.h>

#ifndef MAX
# define MAX(a, b) ((a) > (b) ? (a) : (b))
--
57 changes: 57 additions & 0 deletions media-gfx/gphoto2/gphoto2-2.5.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit autotools

DESCRIPTION="Free, redistributable digital camera software application"
HOMEPAGE="http://www.gphoto.org/"
SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="aalib exif ncurses nls readline"

# aalib -> needs libjpeg
RDEPEND="
dev-libs/popt
>=media-libs/libgphoto2-2.5.17:=[exif?]
aalib? (
media-libs/aalib
virtual/jpeg:0 )
exif? ( media-libs/libexif )
ncurses? ( dev-libs/cdk:0= )
readline? ( sys-libs/readline:0= )
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
nls? ( >=sys-devel/gettext-0.14.1 )
"

PATCHES=(
"${FILESDIR}"/${P}-s-cdk-cdk.h-cdk.h.patch
)

src_prepare() {
default
if ! use exif ; then
# Remove tests that require EXIF to pass, bug 610024
rm "${S}"/tests/data/test0{35,36,37,40}* || die
fi
# Leave GCC debug builds under user control
sed -r '/(C|LD)FLAGS/ s/ -g( |")/\1/' \
-i configure{.ac,} || die
eautoreconf
}

src_configure() {
econf \
$(use_with aalib) \
$(use_with aalib jpeg) \
$(use_with exif libexif auto) \
$(use_with ncurses cdk) \
$(use_enable nls) \
$(use_with readline)
}

0 comments on commit de9268c

Please sign in to comment.