Skip to content

Commit

Permalink
app-text/sablotron: EAPI bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
akhuettel committed Apr 10, 2017
1 parent 2e7a022 commit df1e883
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions app-text/sablotron/sablotron-1.0.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

MY_PN="Sablot"
MY_P="${MY_PN}-${PV}"
S=${WORKDIR}/${MY_P}

DESCRIPTION="An XSLT Parser in C++"
HOMEPAGE="http://www.gingerall.org/sablotron.html"
SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"

# Sablotron can optionally be built under GPL, using MPL for now
LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="perl"

RDEPEND=">=dev-libs/expat-1.95.6-r1"
DEPEND="${RDEPEND}
>=dev-perl/XML-Parser-2.3"

PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )

src_prepare() {
default
sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
eautoreconf
elibtoolize
}

src_configure() {
econf \
$(use_enable perl perlconnect) \
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}

src_install() {
emake DESTDIR="${D}" install
dodoc README README_JS RELEASE src/TODO
}

0 comments on commit df1e883

Please sign in to comment.